aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-crack/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /security/py-crack/Makefile
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'security/py-crack/Makefile')
-rw-r--r--security/py-crack/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/security/py-crack/Makefile b/security/py-crack/Makefile
index 17fd85ead9b9..277412ffa50c 100644
--- a/security/py-crack/Makefile
+++ b/security/py-crack/Makefile
@@ -26,13 +26,10 @@ GNU_CONFIGURE= yes
PLIST_FILES:= ${PYTHONPREFIX_SITELIBDIR:S,${PREFIX}/,,}/_crack.so \
${PYTHONPREFIX_SITELIBDIR:S,${PREFIX}/,,}/crack.py
-CONFIGURE_ENV= "CPPFLAGS=-I${LOCALBASE}/include" \
- "LDFLAGS=-L${LOCALBASE}/lib" \
- "DEFAULT_DICTPATH=${LOCALBASE}/libdata/cracklib/pw_dict"
-
-MAKE_ENV= "LDFLAGS=-L${LOCALBASE}/lib"
-
-CFLAGS+= "-I${LOCALBASE}/include"
+CONFIGURE_ENV= "DEFAULT_DICTPATH=${LOCALBASE}/libdata/cracklib/pw_dict"
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
post-patch:
${REINPLACE_CMD} -e 's/setup(/setup(name="${PORTNAME}",version="${PORTVERSION}",/' \