aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-cracklib/Makefile
diff options
context:
space:
mode:
authorsbz <sbz@FreeBSD.org>2013-06-11 08:52:47 +0800
committersbz <sbz@FreeBSD.org>2013-06-11 08:52:47 +0800
commitf9693150737d3ff4bc5ff53fd73c01cb1a209e89 (patch)
tree4db3765820ee98287efbee6b9b7f4e12c6760681 /security/py-cracklib/Makefile
parent646b4f120c758cc9775b6a39258c6c2248646307 (diff)
downloadfreebsd-ports-gnome-f9693150737d3ff4bc5ff53fd73c01cb1a209e89.tar.gz
freebsd-ports-gnome-f9693150737d3ff4bc5ff53fd73c01cb1a209e89.tar.zst
freebsd-ports-gnome-f9693150737d3ff4bc5ff53fd73c01cb1a209e89.zip
- Update to 2.9.0
- Update pkg-descr - Update WWW - Remove PYTHON OPTION in security/cracklib and made security/py-cracklib a python slave port Reviewed by: crees Approved by: sbz (myself)
Diffstat (limited to 'security/py-cracklib/Makefile')
-rw-r--r--security/py-cracklib/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/security/py-cracklib/Makefile b/security/py-cracklib/Makefile
index fc9447137aef..32bb8dab1dd3 100644
--- a/security/py-cracklib/Makefile
+++ b/security/py-cracklib/Makefile
@@ -1,21 +1,22 @@
# $FreeBSD$
-PORTNAME= cracklib
-PORTVERSION= 2.8.19
-CATEGORIES= security python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= crees@FreeBSD.org
-COMMENT= CPython extension module wrapping the libcrack library
+COMMENT= Python bindings for cracklib
+
+LICENSE= LGPL21
LIB_DEPENDS= crack:${PORTSDIR}/security/cracklib
-USE_PYTHON= yes
-USE_PYDISTUTILS= easy_install
-PYEASYINSTALL_ARCHDEP= yes
+MASTERDIR= ${.CURDIR}/../cracklib
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+PYTHON_SLAVEPORT= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} -e \
+ "{s#__version__ = '[^']*'#__version__ = '${PORTVERSION}'#;}" \
+ ${BUILD_WRKSRC}/*.py
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"