aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-gpgme
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-02-06 23:18:23 +0800
committerjhale <jhale@FreeBSD.org>2018-02-06 23:18:23 +0800
commit16482236827c5ee5a0e67e5be9d341584bd26eaf (patch)
treebbbf2fabafddb93c248afddae8ba2fb417228701 /security/py-gpgme
parent6e02ad81217ce5fbe1057a6498a9dd48de957bdf (diff)
downloadfreebsd-ports-gnome-16482236827c5ee5a0e67e5be9d341584bd26eaf.tar.gz
freebsd-ports-gnome-16482236827c5ee5a0e67e5be9d341584bd26eaf.tar.zst
freebsd-ports-gnome-16482236827c5ee5a0e67e5be9d341584bd26eaf.zip
security/gpgme:
- Add some magic to support the regression tests in the case where the test build directory path length exceeds the maximum socket path length. - Fix shebang in the pinentry test script. At long last, the real reason some of the tests were failing has been discovered! - Remove files/patch-tests_gpg_Makefile.in now that the pinentry script is fixed. - Move USES upward. security/gpgme-cpp: - Remove workaround for Bug 193528 (fixed in GCC 6+) security/gpgme-qt5: - Add full test support. - QT5 testlib only needed for tests at build time. - Add DOXYGEN option to install the API documentation. Prevent the automatic building of the docs if doxygen happens to be installed. - Bump PORTREVISION due to added options / dependency change security/py-gpgme: - Add full test support. - Revert flavor logic move from r460759. The logic being below <bsd.port.options.mk> was the reason it wasn't previously working. - Bump PORTREVISION due to added option
Diffstat (limited to 'security/py-gpgme')
-rw-r--r--security/py-gpgme/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/security/py-gpgme/Makefile b/security/py-gpgme/Makefile
index da04d23b06f3..17cbc7ac6949 100644
--- a/security/py-gpgme/Makefile
+++ b/security/py-gpgme/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,12 +12,6 @@ SLAVEPORT= python
BINDING_NAME= python
PLIST= ${.CURDIR}/pkg-plist
-.if ${FLAVOR:Upy27:Mpy2*}
-CONFIGURE_ARGS+=--enable-languages="python2"
-.else
-CONFIGURE_ARGS+=--enable-languages="python3"
-.endif
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages/gpg/_gpgme.so