aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-gssapi
diff options
context:
space:
mode:
authorbhughes <bhughes@FreeBSD.org>2018-08-02 05:11:34 +0800
committerbhughes <bhughes@FreeBSD.org>2018-08-02 05:11:34 +0800
commitcb7d91f7e8ab8edcd4c176cadf29f1171434b2fa (patch)
treea46c587fee0a8fb8b685f588cb12442ec735cf21 /security/py-gssapi
parent42daba47bbbee33942be30e0d4c3670320dc788f (diff)
downloadfreebsd-ports-gnome-cb7d91f7e8ab8edcd4c176cadf29f1171434b2fa.tar.gz
freebsd-ports-gnome-cb7d91f7e8ab8edcd4c176cadf29f1171434b2fa.tar.zst
freebsd-ports-gnome-cb7d91f7e8ab8edcd4c176cadf29f1171434b2fa.zip
security/py-gssapi: Fix builds against non-base GSSAPI
Patch setup.py so location of krb5-config is configurable PR: 229639 Submitted by: john@saltant.com (maintainer) MFH: 2018Q3 Sponsored by: Miles AS
Diffstat (limited to 'security/py-gssapi')
-rw-r--r--security/py-gssapi/files/patch-setup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/py-gssapi/files/patch-setup.py b/security/py-gssapi/files/patch-setup.py
new file mode 100644
index 000000000000..89ae0d6dacc1
--- /dev/null
+++ b/security/py-gssapi/files/patch-setup.py
@@ -0,0 +1,28 @@
+--- setup.py.orig 2018-04-06 18:43:07 UTC
++++ setup.py
+@@ -55,7 +55,7 @@ if link_args is None:
+ elif os.environ.get('MINGW_PREFIX'):
+ link_args = '-lgss'
+ else:
+- link_args = get_output('krb5-config --libs gssapi')
++ link_args = get_output('%%KRB5CONFIG%% --libs gssapi')
+
+ if compile_args is None:
+ if osx_has_gss_framework:
+@@ -63,14 +63,14 @@ if compile_args is None:
+ elif os.environ.get('MINGW_PREFIX'):
+ compile_args = '-fPIC'
+ else:
+- compile_args = get_output('krb5-config --cflags gssapi')
++ compile_args = get_output('%%KRB5CONFIG%% --cflags gssapi')
+
+ link_args = link_args.split()
+ compile_args = compile_args.split()
+
+ # add in the extra workarounds for different include structures
+ try:
+- prefix = get_output('krb5-config gssapi --prefix')
++ prefix = get_output('%%KRB5CONFIG%% gssapi --prefix')
+ except Exception:
+ print("WARNING: couldn't find krb5-config; assuming prefix of %s"
+ % str(sys.prefix))