aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-htpasswd
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-28 21:23:08 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-28 21:23:08 +0800
commitdf48a0bb4301545f41bcbecc6fbc1267d79728f9 (patch)
tree764d128871d5e31144ee2880955123a51d3a3f10 /security/py-htpasswd
parent309abdf041e343b1586c4eeee56ccde958bf4f87 (diff)
downloadfreebsd-ports-gnome-df48a0bb4301545f41bcbecc6fbc1267d79728f9.tar.gz
freebsd-ports-gnome-df48a0bb4301545f41bcbecc6fbc1267d79728f9.tar.zst
freebsd-ports-gnome-df48a0bb4301545f41bcbecc6fbc1267d79728f9.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'security/py-htpasswd')
-rw-r--r--security/py-htpasswd/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/security/py-htpasswd/Makefile b/security/py-htpasswd/Makefile
index 30c56376a445..2b61f1c8a690 100644
--- a/security/py-htpasswd/Makefile
+++ b/security/py-htpasswd/Makefile
@@ -11,6 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= graudeejs@gmail.com
COMMENT= Replacement for htpasswd
+USES= shebangfix
USE_PYTHON= yes
USE_XZ= yes
@@ -19,11 +20,9 @@ PLIST_FILES= bin/${PORTNAME}.py
NO_BUILD= yes
NO_WRKSUBDIR= yes
-NO_STAGE= yes
-post-patch:
- ${SED} -I.orig -e 's|^#!/usr/bin/python|#!/usr/bin/env python|' ${WRKDIR}/${PORTNAME}.py
+SHEBANG_FILES= ${PORTNAME}.py
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>