aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-mhash/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-04-30 02:53:07 +0800
committerijliao <ijliao@FreeBSD.org>2002-04-30 02:53:07 +0800
commit331c7aa42e2c8939b55ed23f19b5748e0769e3d5 (patch)
tree03a96cddc4a0b6e97a22b4dd2f4a3744a9ee804b /security/py-mhash/Makefile
parent56d207b169a0d4d4b689d659ae52d153a7348437 (diff)
downloadfreebsd-ports-gnome-331c7aa42e2c8939b55ed23f19b5748e0769e3d5.tar.gz
freebsd-ports-gnome-331c7aa42e2c8939b55ed23f19b5748e0769e3d5.tar.zst
freebsd-ports-gnome-331c7aa42e2c8939b55ed23f19b5748e0769e3d5.zip
use USE_PYDISTUTILS
Diffstat (limited to 'security/py-mhash/Makefile')
-rw-r--r--security/py-mhash/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/security/py-mhash/Makefile b/security/py-mhash/Makefile
index fc15080a1826..a9be00088593 100644
--- a/security/py-mhash/Makefile
+++ b/security/py-mhash/Makefile
@@ -19,14 +19,12 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= mhash:${PORTSDIR}/security/mhash
USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_BUILDARGS= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
-SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
-
do-build:
- @${SETUP_CMD} build_ext -L${LOCALBASE}/lib
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} build_ext ${PYDISTUTILS_BUILDARGS})
-do-install:
- @${SETUP_CMD} install
.include <bsd.port.mk>