aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-mhash/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-07-19 02:59:33 +0800
committerpav <pav@FreeBSD.org>2005-07-19 02:59:33 +0800
commit5ea8de73ef0f976937ad4a0f72391cfa2803f4ea (patch)
tree247eb5d12d30f9514f1ff5299c2723f3c3cb2ae6 /security/py-mhash/Makefile
parent59a60d38c5e8e0ed203e3e4a88e509715e3efa0a (diff)
downloadfreebsd-ports-gnome-5ea8de73ef0f976937ad4a0f72391cfa2803f4ea.tar.gz
freebsd-ports-gnome-5ea8de73ef0f976937ad4a0f72391cfa2803f4ea.tar.zst
freebsd-ports-gnome-5ea8de73ef0f976937ad4a0f72391cfa2803f4ea.zip
- Update to 1.4
PR: ports/83654 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
Diffstat (limited to 'security/py-mhash/Makefile')
-rw-r--r--security/py-mhash/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/security/py-mhash/Makefile b/security/py-mhash/Makefile
index e086996336e2..ff58dc81efb4 100644
--- a/security/py-mhash/Makefile
+++ b/security/py-mhash/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= mhash
-PORTVERSION= 1.0
+PORTVERSION= 1.4
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mhash
@@ -19,17 +19,14 @@ COMMENT= Python mhash module
LIB_DEPENDS= mhash:${PORTSDIR}/security/mhash
-PLIST_FILES= lib/%%PYTHON_VERSION%%/site-packages/mhash.so
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/mhash.so
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-USE_REINPLACE= yes
-PYDISTUTILS_BUILDARGS= -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include
-pre-patch:
- ${REINPLACE_CMD} -e '227s,$$,\\,' ${WRKSRC}/mhash.c # put a missed terminating quote
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV= "LDFLAGS=-L${LOCALBASE}/lib"
-do-build:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} build_ext ${PYDISTUTILS_BUILDARGS})
+test: install
+ ${PYTHON_CMD} ${WRKSRC}/test.py
.include <bsd.port.mk>