aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-paramiko
diff options
context:
space:
mode:
authorsbz <sbz@FreeBSD.org>2014-02-07 00:25:21 +0800
committersbz <sbz@FreeBSD.org>2014-02-07 00:25:21 +0800
commit67e193b5b90eb02e258deec6227456a93da7c260 (patch)
treef66876500f896d14ca0a237986b1f12b607ff9f9 /security/py-paramiko
parent42653b36298aa1f461c46b2c601299ab09796a37 (diff)
downloadfreebsd-ports-gnome-67e193b5b90eb02e258deec6227456a93da7c260.tar.gz
freebsd-ports-gnome-67e193b5b90eb02e258deec6227456a93da7c260.tar.zst
freebsd-ports-gnome-67e193b5b90eb02e258deec6227456a93da7c260.zip
- Update to 1.12.1
Diffstat (limited to 'security/py-paramiko')
-rw-r--r--security/py-paramiko/Makefile9
-rw-r--r--security/py-paramiko/distinfo4
-rw-r--r--security/py-paramiko/files/patch-setup.py10
3 files changed, 13 insertions, 10 deletions
diff --git a/security/py-paramiko/Makefile b/security/py-paramiko/Makefile
index 914ea94bc062..e96ce47e5c3f 100644
--- a/security/py-paramiko/Makefile
+++ b/security/py-paramiko/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= paramiko
-PORTVERSION= 1.11.0
+PORTVERSION= 1.12.1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,8 @@ COMMENT= Python SSH2 protocol library
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>0:${PORTSDIR}/security/py-ecdsa
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -20,11 +21,11 @@ PYDISTUTILS_AUTOPLIST= yes
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= EXAMPLES
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @(cd ${WRKSRC}/demos && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
+ (cd ${WRKSRC}/demos && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
regression-test: extract
@(cd ${WRKSRC} && ${PYTHON_CMD} test.py)
diff --git a/security/py-paramiko/distinfo b/security/py-paramiko/distinfo
index 66aeaea31d39..6bc7a89597f9 100644
--- a/security/py-paramiko/distinfo
+++ b/security/py-paramiko/distinfo
@@ -1,2 +1,2 @@
-SHA256 (paramiko-1.11.0.tar.gz) = d46fb8af4c4ffca3c55c600c17354c7c149d8c5dcd7cd6395f4fa0ce2deaca87
-SIZE (paramiko-1.11.0.tar.gz) = 842743
+SHA256 (paramiko-1.12.1.tar.gz) = 792d3735ef91c2f54c1afc8c18341c7a707bfcec19d2d29da76c2758dbd79e8c
+SIZE (paramiko-1.12.1.tar.gz) = 860531
diff --git a/security/py-paramiko/files/patch-setup.py b/security/py-paramiko/files/patch-setup.py
index 5ab4a79f3140..9f90358ed731 100644
--- a/security/py-paramiko/files/patch-setup.py
+++ b/security/py-paramiko/files/patch-setup.py
@@ -1,13 +1,15 @@
---- ./setup.py.orig 2012-10-03 11:45:35.000000000 +0200
-+++ ./setup.py 2012-10-03 11:46:32.000000000 +0200
-@@ -37,14 +37,8 @@
+--- ./setup.py.orig 2014-02-06 14:49:52.000000000 +0100
++++ ./setup.py 2014-02-06 14:51:23.000000000 +0100
+@@ -37,16 +37,8 @@
#ez_setup.use_setuptools()
import sys
-try:
- from setuptools import setup
- kw = {
-- 'install_requires': 'pycrypto >= 2.1, != 2.4',
+- 'install_requires': ['pycrypto >= 2.1, != 2.4',
+- 'ecdsa',
+- ],
- }
-except ImportError:
- from distutils.core import setup