aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-rekall
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-05-25 01:31:07 +0800
committerantoine <antoine@FreeBSD.org>2018-05-25 01:31:07 +0800
commita6588054d97aef1afc3b542b82c74b0dbd79f01a (patch)
tree41ee51ed6ce0fb1a55313b0d6f51e601b73f2401 /security/py-rekall
parent39415d28cbf32ae39232bcfaefff5f9decdc8374 (diff)
downloadfreebsd-ports-gnome-a6588054d97aef1afc3b542b82c74b0dbd79f01a.tar.gz
freebsd-ports-gnome-a6588054d97aef1afc3b542b82c74b0dbd79f01a.tar.zst
freebsd-ports-gnome-a6588054d97aef1afc3b542b82c74b0dbd79f01a.zip
Update to 1.7.2rc1
Diffstat (limited to 'security/py-rekall')
-rw-r--r--security/py-rekall/Makefile19
-rw-r--r--security/py-rekall/distinfo6
-rw-r--r--security/py-rekall/files/patch-setup.py12
3 files changed, 27 insertions, 10 deletions
diff --git a/security/py-rekall/Makefile b/security/py-rekall/Makefile
index ad1e039561d4..b803e2e0b4b6 100644
--- a/security/py-rekall/Makefile
+++ b/security/py-rekall/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rekall
-PORTVERSION= 1.6.0
-PORTREVISION= 1
+DISTVERSION= 1.7.2rc1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,13 +12,23 @@ COMMENT= Memory forensics analysis framework
LICENSE= GPLv2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}rekall-core>=1.5.0.p:security/py-rekall-core@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ipython>=5.0.0:devel/ipython@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}rekall_lib>=1.7.1:security/py-rekall_lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rekall-core>=1.7.1:security/py-rekall-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipython>=5.0.0:devel/ipython@${PY_FLAVOR}
NO_ARCH= yes
-USES= python:2.7 zip
+USES= python shebangfix zip
USE_PYTHON= distutils autoplist
+python_OLD_CMD= python
+SHEBANG_FILES= tools/devel/autopep8.sh \
+ tools/devel/presubmit.sh \
+ tools/linux/lmap/tools/fix_versions.py \
+ tools/profiles/unpack_kdbg_kit.py \
+ tools/testing/tap.py \
+ tools/testing/test_suite.py \
+ tools/windows/winpmem/winpmem.py
+
.include <bsd.port.pre.mk>
PYDISTUTILS_INSTALLARGS+=--install-data ${DATADIR}
diff --git a/security/py-rekall/distinfo b/security/py-rekall/distinfo
index 55057316113a..aa243c4dd6bd 100644
--- a/security/py-rekall/distinfo
+++ b/security/py-rekall/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478337079
-SHA256 (rekall-1.6.0.zip) = 261cbc31c4f1eb91b8e2cefb7a5bbfe547539b091d58ff7d91f181494ae0af8a
-SIZE (rekall-1.6.0.zip) = 301230
+TIMESTAMP = 1517735306
+SHA256 (rekall-1.7.2rc1.zip) = 08134cd142203130c8d09e6e52114b4f5e17211bc9993d507ce4a69b5aa2e072
+SIZE (rekall-1.7.2rc1.zip) = 1733715
diff --git a/security/py-rekall/files/patch-setup.py b/security/py-rekall/files/patch-setup.py
index 9c3d690e58e5..591b2916740a 100644
--- a/security/py-rekall/files/patch-setup.py
+++ b/security/py-rekall/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2016-11-03 22:17:38 UTC
+--- setup.py.orig 2017-11-05 21:24:44 UTC
+++ setup.py
-@@ -80,7 +80,8 @@ def find_data_files(source):
+@@ -82,7 +82,8 @@ def find_data_files(source):
result = []
for directory, _, files in os.walk(source):
files = [os.path.join(directory, x) for x in files]
@@ -10,3 +10,11 @@
return result
+@@ -95,7 +96,6 @@ commands = dict(
+ # This requires an exact version to ensure that installing the meta package
+ # pulls in tested dependencies.
+ install_requires = [
+- "rekall-agent >= 1.7.0rc1, < 1.8",
+ "rekall-lib >= 1.7.0rc1, < 1.8",
+ "rekall-core >= 1.7.0rc1, < 1.8",
+ "ipython >= 5.0.0, < 7.0",