aboutsummaryrefslogtreecommitdiffstats
path: root/security/qtfw
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 12:57:17 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 12:57:17 +0800
commit020cd998029533b2188adeb43fcaea70649cf8be (patch)
treee48edaad7fd3f0ccd91f151e72ede8ca143031fb /security/qtfw
parent7e0afc569539fa9b4b9213cc8b416050279b973a (diff)
downloadfreebsd-ports-gnome-020cd998029533b2188adeb43fcaea70649cf8be.tar.gz
freebsd-ports-gnome-020cd998029533b2188adeb43fcaea70649cf8be.tar.zst
freebsd-ports-gnome-020cd998029533b2188adeb43fcaea70649cf8be.zip
Fix the code so GCC 3.4.2 likes it better, and unbreak.
Reported by: kris Approved by: portmgr (krion), fjoe (mentor, implicit)
Diffstat (limited to 'security/qtfw')
-rw-r--r--security/qtfw/Makefile8
-rw-r--r--security/qtfw/files/patch-fwrule.cpp9
2 files changed, 10 insertions, 7 deletions
diff --git a/security/qtfw/Makefile b/security/qtfw/Makefile
index 0e9f7180c2e2..4f81be141df3 100644
--- a/security/qtfw/Makefile
+++ b/security/qtfw/Makefile
@@ -22,13 +22,7 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
PLIST_FILES= bin/qtfw
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/qtfw ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/qtfw/files/patch-fwrule.cpp b/security/qtfw/files/patch-fwrule.cpp
index 979c53b9e120..22e5d7d8ed3b 100644
--- a/security/qtfw/files/patch-fwrule.cpp
+++ b/security/qtfw/files/patch-fwrule.cpp
@@ -8,3 +8,12 @@
#define IPPROTO_IP 0
+@@ -547,7 +547,7 @@
+ nCurrentIndex++;
+ ac++;
+ }
+- av = new (char*)[ac];
++ av = new char*[ac];
+
+ /* Now fill the av[] array */
+ for (int i =0;i < ac;i++)