aboutsummaryrefslogtreecommitdiffstats
path: root/security/racoon2
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2016-04-15 22:28:44 +0800
committercy <cy@FreeBSD.org>2016-04-15 22:28:44 +0800
commitba12faf86000d9a1eadecd75d45a58d728e09c0b (patch)
tree40adf851e326de9859372d82e08c77424f6ac2a0 /security/racoon2
parente7f3ca75b0f22eb17f416c6203079b0554464e0b (diff)
downloadfreebsd-ports-gnome-ba12faf86000d9a1eadecd75d45a58d728e09c0b.tar.gz
freebsd-ports-gnome-ba12faf86000d9a1eadecd75d45a58d728e09c0b.tar.zst
freebsd-ports-gnome-ba12faf86000d9a1eadecd75d45a58d728e09c0b.zip
Support the various forms of Kerberos via options.
PR: 207507
Diffstat (limited to 'security/racoon2')
-rw-r--r--security/racoon2/Makefile78
-rw-r--r--security/racoon2/pkg-plist2
2 files changed, 59 insertions, 21 deletions
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index d3fbd1b9a9b4..fd58a6aa2181 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= racoon2
PORTVERSION= 20100526a
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= security net ipv6
MASTER_SITES= ftp://ftp.racoon2.wide.ad.jp/pub/racoon2/
@@ -13,6 +13,8 @@ COMMENT= Racoon2 IPsec daemon
USES= perl5 tar:tgz
USE_RC_SUBR= YES
USE_OPENSSL= YES
+CONFIGURE_ARGS+= --disable-kinkd
+PLIST_SUB+= KINK="@comment "
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
@@ -20,34 +22,70 @@ CONFIGURE_ARGS+= --prefix=${STAGEDIR}${PREFIX}
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/racoon2
CONFIGURE_ENV= YACC=/usr/bin/yacc perl_bindir=${LOCALBASE}/bin/perl5
-OPTIONS_DEFINE= KINK DOCS
-KINK_DESC= Enable KINK support
+OPTIONS_DEFINE= DOCS
+OPTIONS_RADIO= KERBEROS
+OPTIONS_RADIO_KERBEROS= KRB5 KRB5_112 KRB5_113 KRB5_114 \
+ HEIMDAL_PORTS HEIMDAL_BASE
+KRB5_DESC= Build with Kerberos (security/krb5)
+KRB5_112_DESC= Build with Kerberos (security/krb5-112)
+KRB5_113_DESC= Build with Kerberos (security/krb5-113)
+KRB5_114_DESC= Build with Kerberos (security/krb5-114)
+HEIM_AL_PORTS_DESC= Build with Heimdal in ports (security/heimdal)
+HEIMDAL_BASE_DESC= Build with Heimdal in base
+
+KRB5_USES= gssapi:mit
+KRB5_CONFIGURE_ON= --enable-kinkd
+KRB5_MAKE_ENV= WITH_KINK=yes
+KRB5_PLIST_SUB= KINK=""
+KRB5_LIB_DEPENDS= libkrb5support.so:${PORTSDIR}/security/krb5
+KRB5_RUN_DEPENDS= kinit:${PORTSDIR}/security/krb5
+KRB5_VARS= KINK=yes
+
+KRB5_112_USES= gssapi:mit
+KRB5_112_CONFIGURE_ON= --enable-kinkd
+KRB5_112_MAKE_ENV= WITH_KINK=yes
+KRB5_112_PLIST_SUB= KINK=""
+KRB5_112_LIB_DEPENDS= libkrb5support.so:${PORTSDIR}/security/krb5-112
+KRB5_112_RUN_DEPENDS= kinit:${PORTSDIR}/security/krb5-112
+KRB5_112_VARS= KINK=yes
+
+KRB5_113_USES= gssapi:mit
+KRB5_113_CONFIGURE_ON= --enable-kinkd
+KRB5_113_MAKE_ENV= WITH_KINK=yes
+KRB5_113_PLIST_SUB= KINK=""
+KRB5_113_LIB_DEPENDS= libkrb5support.so:${PORTSDIR}/security/krb5-113
+KRB5_113_RUN_DEPENDS= kinit:${PORTSDIR}/security/krb5-113
+KRB5_113_VARS= KINK=yes
+
+KRB5_114_USES= gssapi:mit
+KRB5_114_CONFIGURE_ON= --enable-kinkd
+KRB5_114_MAKE_ENV= WITH_KINK=yes
+KRB5_114_PLIST_SUB= KINK=""
+KRB5_114_LIB_DEPENDS= libkrb5support.so:${PORTSDIR}/security/krb5-114
+KRB5_114_RUN_DEPENDS= kinit:${PORTSDIR}/security/krb5-113
+KRB5_114_VARS= KINK=yes
+
+HEIMDAL_PORT_USES= gssapi:heimdal
+HEIMDAL_PORTS_CONFIGURE_ON= --enable-kinkd
+HEIMDAL_PORTS_MAKE_ENV= WITH_KINK=yes
+HEIMDAL_PORT_PLIST_SUB= KINK=""
+HEIMDAL_PORT_VARS= KINK=yes
+
+HEIMDAL_BASE_USES= gssapi:base
+HEIMDAL_BASE_CONFIGURE_ON= --enable-kinkd
+HEIMDAL_BASE_MAKE_ENV= WITH_KINK=yes
+HEIMDAL_BASE_PLIST_SUB= KINK=""
+HEIMDAL_BASE_VARS= KINK=yes
.include <bsd.port.pre.mk>
PLIST_SUB+= PFX=${PREFIX}
-pre-configure:
-.if ${PORT_OPTIONS:MKINK}
-.if !exists(/usr/lib/libkrb5.a)
- @${ECHO_MSG} 'Required Kerberos5 is not in this system. Disable KINK support.'
-CONFIGURE_ARGS+= --disable-kinkd
-PLIST_SUB+= KINK="@comment "
-.else
-CONFIGURE_ARGS+= --enable-kinkd
-MAKE_ENV= WITH_KINK=yes
-PLIST_SUB+= KINK=""
-.endif
-.else
-CONFIGURE_ARGS+= --disable-kinkd
-PLIST_SUB+= KINK="@comment "
-.endif
-
.if ${PORT_OPTIONS:MDOCS}
PORTDOCS+= INSTALL USAGE config-usage.ja.txt config-usage.txt
PORTDOCS+= iked-memo.ja.txt libracoon.ja.txt specification.ja.txt
PORTDOCS+= spmif.txt style.txt system-message.ja.txt
-.if ${PORT_OPTIONS:MKINK}
+.if defined(KINK)
PORTDOCS+= kinkd-data-struct.obj kinkd-impl.ja.txt
PORTDOCS+= kinkd-install.ja.txt kinkd-state-txn.obj
.endif
diff --git a/security/racoon2/pkg-plist b/security/racoon2/pkg-plist
index 5e43770451a2..5c2d97b3cde0 100644
--- a/security/racoon2/pkg-plist
+++ b/security/racoon2/pkg-plist
@@ -44,6 +44,6 @@ man/man8/iked.8.gz
@dir etc/racoon2/hook/child-rekey.d
@dir etc/racoon2/hook/child-down.d
@dir etc/racoon2/cert
-@exec test -f %%PFX%%/etc/racoon2/spmd.pwd && mv %%PFX%%/etc/racoon2/spmd.pwd %%PFX%%/etc/racoon2/spmd.pwd.bak && %%PFX%%/pskgen -r -o %%PFX%%/etc/racoon2/spmd.pwd
+@exec test -f %%PFX%%/etc/racoon2/spmd.pwd && mv %%PFX%%/etc/racoon2/spmd.pwd %%PFX%%/etc/racoon2/spmd.pwd.bak && %%PFX%%/sbin/pskgen -r -o %%PFX%%/etc/racoon2/spmd.pwd
@unexec rm -f %%PFX/etc/racoon2/spmd.pwd
@dir(root,wheel,700) /var/run/racoon2