aboutsummaryrefslogtreecommitdiffstats
path: root/security/razorback-scriptNugget
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-21 01:53:11 +0800
committermarino <marino@FreeBSD.org>2014-08-21 01:53:11 +0800
commita4e861cf7bc3c70dbd4801f3074492d15299c767 (patch)
tree8e7afbb0183c955ddfdc4ecc64fdbeb32e6f39e5 /security/razorback-scriptNugget
parent10b429ae9e94167a140127ac02d4f01dabec1953 (diff)
downloadfreebsd-ports-gnome-a4e861cf7bc3c70dbd4801f3074492d15299c767.tar.gz
freebsd-ports-gnome-a4e861cf7bc3c70dbd4801f3074492d15299c767.tar.zst
freebsd-ports-gnome-a4e861cf7bc3c70dbd4801f3074492d15299c767.zip
security/razorback-scriptNugget: Chase json-c update (Unbreak)
Diffstat (limited to 'security/razorback-scriptNugget')
-rw-r--r--security/razorback-scriptNugget/Makefile6
-rw-r--r--security/razorback-scriptNugget/files/patch-common__m4_api__deps.m411
-rw-r--r--security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m411
3 files changed, 26 insertions, 2 deletions
diff --git a/security/razorback-scriptNugget/Makefile b/security/razorback-scriptNugget/Makefile
index c55623db13a9..17d91618156f 100644
--- a/security/razorback-scriptNugget/Makefile
+++ b/security/razorback-scriptNugget/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scriptNugget
PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF/razorbacktm/Nuggets
PKGNAMEPREFIX= razorback-
@@ -15,13 +15,15 @@ COMMENT= Framework for an intelligence driven security - Scripting Interface
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api
+LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api \
+ libjson-c.so:${PORTSDIR}/devel/json-c
BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget
RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
rubygem-razorback-scriptNugget>=0.5.0:${PORTSDIR}/security/rubygem-razorback-scriptNugget
RB_LIBDIR?= ${PREFIX}/lib/razorback
USES= libtool pkgconfig
+USE_AUTOTOOLS= autoconf
USE_GNOME= libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-ruby
diff --git a/security/razorback-scriptNugget/files/patch-common__m4_api__deps.m4 b/security/razorback-scriptNugget/files/patch-common__m4_api__deps.m4
new file mode 100644
index 000000000000..b424f894f261
--- /dev/null
+++ b/security/razorback-scriptNugget/files/patch-common__m4_api__deps.m4
@@ -0,0 +1,11 @@
+--- common_m4/api_deps.m4.orig 2012-04-16 18:59:44 UTC
++++ common_m4/api_deps.m4
+@@ -55,7 +55,7 @@ LIBS="$LIBCONFIG_LIBS $LIBS"
+ # [AC_MSG_ERROR("curl header file not found")]
+ # )
+
+-PKG_CHECK_MODULES([JSON], [json >= 0.9])
++PKG_CHECK_MODULES([JSON], [json-c >= 0.9])
+
+ CFLAGS="$JSON_CFLAGS $CFLAGS"
+ LIBS="$JSON_LIBS $LIBS"
diff --git a/security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m4 b/security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m4
new file mode 100644
index 000000000000..8e2572727b90
--- /dev/null
+++ b/security/razorback-scriptNugget/files/patch-common__m4_compiler__options.m4
@@ -0,0 +1,11 @@
+--- common_m4/compiler_options.m4.orig 2012-01-04 18:17:09 UTC
++++ common_m4/compiler_options.m4
+@@ -28,7 +28,7 @@ if test "$GCC" = yes ; then
+
+ CFLAGS="$CFLAGS -std=c99 -fno-strict-aliasing"
+ CPPFLAGS="$CPPFLAGS -fno-strict-aliasing"
+- CWARNINGS="$CWARNINGS -Wall -Werror -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
++ CWARNINGS="$CWARNINGS -Wall -Wwrite-strings -Wformat -fdiagnostics-show-option -Wextra -Wformat-security -Wsign-compare -Wcast-align -Wno-unused-parameter"
+ if test "x$NOT_PEDANTIC" = "x"; then
+ CWARNINGS="$CWARNINGS -pedantic"
+ fi