aboutsummaryrefslogtreecommitdiffstats
path: root/security/revelation
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-06-17 23:32:04 +0800
committermiwi <miwi@FreeBSD.org>2013-06-17 23:32:04 +0800
commitf1e1d9e7c9ca207bd176ec52b31ee482419b3eb4 (patch)
treeb03df065d9b2307d9e73d1bdbf7aaa5793cb6f1b /security/revelation
parent974ada6ac0f82a9c74fabb4b78165bd1459bea30 (diff)
downloadfreebsd-ports-gnome-f1e1d9e7c9ca207bd176ec52b31ee482419b3eb4.tar.gz
freebsd-ports-gnome-f1e1d9e7c9ca207bd176ec52b31ee482419b3eb4.tar.zst
freebsd-ports-gnome-f1e1d9e7c9ca207bd176ec52b31ee482419b3eb4.zip
- Add RUN_DEPENDS for security/py-cracklib
- Support desktop-file-utils/shebangfix/shared-mime-info PR: 179594 Submitted by: Ports Fury
Diffstat (limited to 'security/revelation')
-rw-r--r--security/revelation/Makefile31
-rw-r--r--security/revelation/pkg-plist8
2 files changed, 8 insertions, 31 deletions
diff --git a/security/revelation/Makefile b/security/revelation/Makefile
index b533c33eb93a..e5a4a8134233 100644
--- a/security/revelation/Makefile
+++ b/security/revelation/Makefile
@@ -3,6 +3,7 @@
PORTNAME= revelation
PORTVERSION= 0.4.14
+PORTREVISION= 1
CATEGORIES= security gnome
MASTER_SITES= http://cdn.bitbucket.org/erikg/revelation/downloads/
@@ -11,18 +12,20 @@ COMMENT= Password manager for the GNOME 2 desktop
LICENSE= GPLv2
-FETCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/security/cracklib:patch
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:${PORTSDIR}/devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto
LIB_DEPENDS= crack:${PORTSDIR}/security/cracklib
-RUN_DEPENDS:= ${BULID_DEPENDS}
+RUN_DEPENDS:= ${BULID_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}cracklib>0:${PORTSDIR}/security/py-cracklib
OPTIONS_DEFINE= APPLET
APPLET_DESC= Build with applet
USE_BZIP2= yes
-USES= pathfix pkgconfig gettext
-USE_GNOME= desktopfileutils gnomeprefix pygnome2
+USES= desktop-file-utils gettext pathfix pkgconfig \
+ shared-mime-info shebangfix
+SHEBANG_FILES= src/revelation.py
+USE_GNOME= gnomeprefix pygnome2
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -47,27 +50,9 @@ PLIST_SUB+= APPLET=""
PLIST_SUB+= APPLET="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-CRACK_WRKSRC= $$(cd ${PORTSDIR}/security/cracklib && ${MAKE} -V WRKSRC)
-
post-patch:
@${REINPLACE_CMD} -e \
- 's|^#!.*|#!${SETENV} python|' ${WRKSRC}/src/revelation.py
- @${REINPLACE_CMD} -e \
'/FascistCheck/s|(password)|(password, "${DICTPATH}")|' \
${WRKSRC}/src/lib/util.py
-post-build:
- @(cd ${CRACK_WRKSRC}/python && ${CC} -shared -fPIC \
- -I${PYTHON_INCLUDEDIR} -I${LOCALBASE}/include ${CFLAGS} \
- -o _cracklib.so _cracklib.c -L${LOCALBASE}/lib -lcrack -lz)
- @${PYTHON_CMD} -m compileall ${CRACK_WRKSRC}/python
- @${PYTHON_CMD} -O -m compileall ${CRACK_WRKSRC}/python
-
-post-install:
- (cd ${CRACK_WRKSRC}/python && ${INSTALL_DATA} \
- _cracklib.so cracklib.py* \
- ${PYTHONPREFIX_SITELIBDIR}/revelation)
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/revelation/pkg-plist b/security/revelation/pkg-plist
index 9e2cce67d06c..1170ce57ebb4 100644
--- a/security/revelation/pkg-plist
+++ b/security/revelation/pkg-plist
@@ -1,5 +1,4 @@
bin/revelation
-%%PYTHON_SITELIBDIR%%/revelation/_cracklib.so
%%PYTHON_SITELIBDIR%%/revelation/PBKDF2.py
%%PYTHON_SITELIBDIR%%/revelation/PBKDF2.pyc
%%PYTHON_SITELIBDIR%%/revelation/PBKDF2.pyo
@@ -21,9 +20,6 @@ bin/revelation
%%PYTHON_SITELIBDIR%%/revelation/config.py
%%PYTHON_SITELIBDIR%%/revelation/config.pyc
%%PYTHON_SITELIBDIR%%/revelation/config.pyo
-%%PYTHON_SITELIBDIR%%/revelation/cracklib.py
-%%PYTHON_SITELIBDIR%%/revelation/cracklib.pyc
-%%PYTHON_SITELIBDIR%%/revelation/cracklib.pyo
%%PYTHON_SITELIBDIR%%/revelation/data.py
%%PYTHON_SITELIBDIR%%/revelation/data.pyc
%%PYTHON_SITELIBDIR%%/revelation/data.pyo
@@ -112,7 +108,3 @@ share/mime/packages/revelation.xml
@dirrm %%PYTHON_SITELIBDIR%%/revelation/datahandler
@dirrm %%PYTHON_SITELIBDIR%%/revelation/bundle
@dirrm %%PYTHON_SITELIBDIR%%/revelation
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime