aboutsummaryrefslogtreecommitdiffstats
path: root/security/rkhunter/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-13 06:06:38 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-13 06:06:38 +0800
commitf765609fbb72da8e6418b841cb872580cb61b5f0 (patch)
tree9b0c5cf68ac591b3e37c9c6696f0ab0a5e7eedb3 /security/rkhunter/Makefile
parenteab4eb30b1914b065a815432bae04961f9cbe94b (diff)
downloadfreebsd-ports-gnome-f765609fbb72da8e6418b841cb872580cb61b5f0.tar.gz
freebsd-ports-gnome-f765609fbb72da8e6418b841cb872580cb61b5f0.tar.zst
freebsd-ports-gnome-f765609fbb72da8e6418b841cb872580cb61b5f0.zip
- Add OPTIONS for nmap (default on) and lsof (default off) RUN_DEPENDs for
additional checks - bump portrevision PR: ports/99432 Submitted by: Babak Farrokhi <babak@farrokhi.net> Approved by: maintianer timeout
Diffstat (limited to 'security/rkhunter/Makefile')
-rw-r--r--security/rkhunter/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/security/rkhunter/Makefile b/security/rkhunter/Makefile
index 0b3a55261c0e..47d78e71f672 100644
--- a/security/rkhunter/Makefile
+++ b/security/rkhunter/Makefile
@@ -7,14 +7,17 @@
PORTNAME= rkhunter
PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://downloads.rootkit.nl/
MAINTAINER= vaidab@safe-mail.net
COMMENT= Rootkit detection tool
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+OPTIONS= LSOF "Use LSOF" on \
+ NMAP "Use NMAP" off
+
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -28,6 +31,14 @@ PORTDOCS= CHANGELOG README WISHLIST
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_LSOF)
+RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof
+.endif
+
+.if defined(WITH_NMAP)
+RUN_DEPENDS+= nmap:${PORTSDIR}/security/nmap
+.endif
+
.if ${ARCH} == "sparc64"
BROKEN= Does not build on sparc64
.endif