aboutsummaryrefslogtreecommitdiffstats
path: root/security/rkhunter
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2014-08-13 02:31:26 +0800
committercs <cs@FreeBSD.org>2014-08-13 02:31:26 +0800
commit0bee708cfcd992264497ccf68b754114f66d6e07 (patch)
tree8a08f8becde338d02f5a3d62b7cee2baec0f0664 /security/rkhunter
parent52d5a8e097218ccd644e2d4e6ba99e341e6f0eb3 (diff)
downloadfreebsd-ports-gnome-0bee708cfcd992264497ccf68b754114f66d6e07.tar.gz
freebsd-ports-gnome-0bee708cfcd992264497ccf68b754114f66d6e07.tar.zst
freebsd-ports-gnome-0bee708cfcd992264497ccf68b754114f66d6e07.zip
- unbreak
- added some FreeBSD defaults regarding SSH - made port more PREFIX aware - changed maintainer PR: 191842 Submitted by: Gerard J. Cerchio and Lukasz Wasikowski (maintainer)
Diffstat (limited to 'security/rkhunter')
-rw-r--r--security/rkhunter/Makefile9
-rw-r--r--security/rkhunter/files/patch-files__rkhunter.conf64
2 files changed, 63 insertions, 10 deletions
diff --git a/security/rkhunter/Makefile b/security/rkhunter/Makefile
index 9ca5a4da60e9..ff4c373c9c37 100644
--- a/security/rkhunter/Makefile
+++ b/security/rkhunter/Makefile
@@ -3,10 +3,11 @@
PORTNAME= rkhunter
PORTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lukasz@wasikowski.net
COMMENT= Rootkit detection tool
LICENSE= GPLv2
@@ -27,8 +28,10 @@ LSOF_RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
NMAP_RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
post-patch:
- @${REINPLACE_CMD} -e 's|{SHAREDIR}/man/man8|{PREFIX}/man/man8|g' \
+ @${REINPLACE_CMD} -i '' -e 's|{SHAREDIR}/man/man8|{PREFIX}/man/man8|g' \
${WRKSRC}/installer.sh
+ @${REINPLACE_CMD} -i '' -e 's|RKHPREFIX|${PREFIX}|g' \
+ ${WRKSRC}/files/${PORTNAME}.conf
do-install:
cd ${WRKSRC} && ./installer.sh --layout custom ${STAGEDIR}${PREFIX} --install
@@ -40,7 +43,7 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/files/|} ${STAGEDIR}${DOCSDIR}
post-install:
- ${REINPLACE_CMD} -i '' -e 's,${STAGEDIR},,' \
+ @${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||g' \
${STAGEDIR}${PREFIX}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf
${INSTALL_DATA} ${WRKSRC}/files/${PORTNAME}.conf ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
${INSTALL_DATA} -m 640 ${WRKSRC}/files/programs_bad.dat ${STAGEDIR}${PREFIX}/var/lib/${PORTNAME}/db/programs_bad.dat.sample
diff --git a/security/rkhunter/files/patch-files__rkhunter.conf b/security/rkhunter/files/patch-files__rkhunter.conf
index 849f14578c4d..f2b914d2e994 100644
--- a/security/rkhunter/files/patch-files__rkhunter.conf
+++ b/security/rkhunter/files/patch-files__rkhunter.conf
@@ -1,17 +1,60 @@
---- files/rkhunter.conf.orig 2014-06-06 09:59:35.000000000 -0400
-+++ files/rkhunter.conf 2014-06-06 10:01:32.000000000 -0400
-@@ -575,6 +575,10 @@
+--- files/rkhunter.conf.orig 2014-01-25 22:29:51.000000000 +0100
++++ files/rkhunter.conf 2014-08-11 23:18:14.887973000 +0200
+@@ -154,7 +154,7 @@
+ # subsequently commented out or removed, then the program will assume a
+ # default directory beneath the installation directory.
+ #
+-#TMPDIR=/var/lib/rkhunter/tmp
++TMPDIR=RKHPREFIX/var/lib/rkhunter/tmp
+
+ #
+ # This option specifies the database directory to use.
+@@ -163,7 +163,7 @@
+ # subsequently commented out or removed, then the program will assume a
+ # default directory beneath the installation directory.
+ #
+-#DBDIR=/var/lib/rkhunter/db
++DBDIR=RKHPREFIX/var/lib/rkhunter/db
+
+ #
+ # This option specifies the script directory to use.
+@@ -171,7 +171,7 @@
+ # The installer program will set the default directory. If this default is
+ # subsequently commented out or removed, then the program will not run.
+ #
+-#SCRIPTDIR=/usr/local/lib/rkhunter/scripts
++SCRIPTDIR=RKHPREFIX/lib/rkhunter/scripts
+
+ #
+ # This option can be used to modify the command directory list used by rkhunter
+@@ -303,7 +303,7 @@
+ #
+ # The default value is 'no'.
+ #
+-#ALLOW_SSH_ROOT_USER=no
++ALLOW_SSH_ROOT_USER=unset
+
+ #
+ # Set this option to '1' to allow the use of the SSH-1 protocol, but note
+@@ -317,7 +317,7 @@
+ #
+ # The default value is '0'.
+ #
+-#ALLOW_SSH_PROT_V1=0
++ALLOW_SSH_PROT_V1=2
+
+ #
+ # This setting tells rkhunter the directory containing the SSH configuration
+@@ -575,6 +575,8 @@
# The default value is the null string.
#
#SCRIPTWHITELIST=/usr/bin/groups
+SCRIPTWHITELIST=/usr/bin/whatis
+SCRIPTWHITELIST=/usr/sbin/adduser
-+SCRIPTWHITELIST=/usr/local/bin/GET
-+SCRIPTWHITELIST=/usr/local/sbin/pkgdb
#
# Allow the specified file to have the immutable attribute set.
-@@ -584,6 +588,10 @@
+@@ -584,6 +586,10 @@
# The default value is the null string.
#
#IMMUTWHITELIST=/sbin/ifdown
@@ -22,7 +65,7 @@
#
# If this option is set to '1', then the immutable-bit test is reversed. That
-@@ -787,6 +795,7 @@
+@@ -787,6 +793,7 @@
# The default value is the null string.
#
#UID0_ACCOUNTS=toor rooty
@@ -30,3 +73,10 @@
#
# This option allows the specified accounts to have no password. NIS/YP entries
+@@ -1222,3 +1229,6 @@
+ #
+ #EMPTY_LOGFILES=""
+ #MISSING_LOGFILES=""
++
++INSTALLDIR=RKHPREFIX
++USER_FILEPROP_FILES_DIRS=RKHPREFIX/etc/rkhunter.conf