aboutsummaryrefslogtreecommitdiffstats
path: root/security/ruby-mcrypt
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2007-10-12 03:59:57 +0800
committerjohans <johans@FreeBSD.org>2007-10-12 03:59:57 +0800
commit58e9a4e11949fc04a9f20ccad25b38eec21d3a12 (patch)
tree32f67770bf504c45ab06a5229ab961d718534375 /security/ruby-mcrypt
parent2fc915673a46c6bd5b8bfa1c7527ecf4083621e0 (diff)
downloadfreebsd-ports-gnome-58e9a4e11949fc04a9f20ccad25b38eec21d3a12.tar.gz
freebsd-ports-gnome-58e9a4e11949fc04a9f20ccad25b38eec21d3a12.tar.zst
freebsd-ports-gnome-58e9a4e11949fc04a9f20ccad25b38eec21d3a12.zip
- Fix compilation with gcc 4.2
- Note: testfile still fails, but does exactly the same with old gcc might be a broken test - leaving this to somebody with ruby-foo
Diffstat (limited to 'security/ruby-mcrypt')
-rw-r--r--security/ruby-mcrypt/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/security/ruby-mcrypt/Makefile b/security/ruby-mcrypt/Makefile
index 75246b31450d..800144f93245 100644
--- a/security/ruby-mcrypt/Makefile
+++ b/security/ruby-mcrypt/Makefile
@@ -27,6 +27,10 @@ INSTALL_TARGET= site-install
DOCS_EN= ChangeLog README TODO
+post-patch:
+ @${REINPLACE_CMD} -e 's/MCRYPT..(void..)/void, /' \
+ ${WRKSRC}/ruby-mcrypt.c
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -37,10 +41,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>