aboutsummaryrefslogtreecommitdiffstats
path: root/security/samhain
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-07 15:56:03 +0800
committeredwin <edwin@FreeBSD.org>2006-01-07 15:56:03 +0800
commit640ae9ea489103ec6eef81eb4040209b2f2d31be (patch)
treefabe6e487d3cc1dea444c80fed816426e7e79a03 /security/samhain
parent44bd62f3d3bbdd31a58e440b0df2fde42cd57cfe (diff)
downloadfreebsd-ports-gnome-640ae9ea489103ec6eef81eb4040209b2f2d31be.tar.gz
freebsd-ports-gnome-640ae9ea489103ec6eef81eb4040209b2f2d31be.tar.zst
freebsd-ports-gnome-640ae9ea489103ec6eef81eb4040209b2f2d31be.zip
Update: security/samhain 2.0.10 -> 2.1.0
Updating the Samhain integrity checking system to 2.1.0, a bugfix release. It's been requested by several people to break Samhain out into separate client and server ports. This PR does that, with a samhain-client and samhain-server port, as slave ports off of samhain. I'm not sure the best way to submit a PR to do this kind of action, but here is a shar of all three ports. If another format is desired, please let me know. I'm also interested in feedback on the approach used for splitting these out. PR: ports/90305 Submitted by: David Thiel <lx@redundancy.redundancy.org>
Diffstat (limited to 'security/samhain')
-rw-r--r--security/samhain/Makefile30
-rw-r--r--security/samhain/distinfo4
-rw-r--r--security/samhain/pkg-plist1
3 files changed, 11 insertions, 24 deletions
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index a0079778449c..e92de49c3a84 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -3,23 +3,9 @@
# Whom: lx
#
# $FreeBSD$
-#
-#
-# This port recognizes the following non-boolean tunables:
-#
-# WITH_RUNAS_USER:
-# Whe building with "WITH_SERVER" defined, the username of the
-# account Yule will run as. Defaults to "yule". If using
-# WITH_GPG, ensure that this user exists and has a pgp
-# keypair before installing.
-#
-# WITH_LOG_SERVER, WITH_ALT_LOG_SERVER. When "WITH_CLIENT" is defined,
-# these specify what server the client will fetch configuration
-# and database files from. This can also be defined at runtime.
-#
PORTNAME= samhain
-PORTVERSION= 2.0.10
+PORTVERSION= 2.1.0
CATEGORIES= security
MASTER_SITES= http://la-samhna.de/archive/ \
http://cold.darkambient.net/
@@ -33,12 +19,12 @@ OPTIONS= KCHECK "Enable rogue KLD detection" off \
MYSQL "Enable MySQL logging" off \
POSTGRESQL "Enable PostgreSQL logging" off \
XML_LOGS "Enable XML-formatted logs" on \
- LIBWRAP "Enable TCP wrapper support" on \
- CLIENT "Build as Samhain network client" off \
- SERVER "Build as Yule network server" off
+ LIBWRAP "Enable TCP wrapper support" on
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CONFLICTS= samhain-client-2*
+
.include <bsd.port.pre.mk>
.if defined(WITH_GPG)
@@ -105,15 +91,15 @@ pre-everything::
.if !defined(WITH_CLIENT) && !defined(WITH_SERVER)
@${ECHO_MSG}
- @${ECHO_MSG} "Building in standalone mode."
+ @${ECHO_MSG} "Building Samhain in standalone mode."
@${ECHO_MSG} "If you wish to enable networked mode, please hit CTRL-C"
- @${ECHO_MSG} "now, review the options in the Makefile, and make"
- @${ECHO_MSG} "with WITH_SERVER=yes or WITH_CLIENT=yes."
+ @${ECHO_MSG} "now, and build samhain from the samhain-client and"
+ @${ECHO_MSG} "samhain-server ports."
@${ECHO_MSG}
.endif
.if defined(WITH_CLIENT) && defined(WITH_SERVER)
-IGNORE= Can't build client and server at once
+IGNORE= can't build client and server at once
.endif
.if defined(WITH_KCHECK)
diff --git a/security/samhain/distinfo b/security/samhain/distinfo
index 01ec16b4e48e..3fddc2ae0e1b 100644
--- a/security/samhain/distinfo
+++ b/security/samhain/distinfo
@@ -1,2 +1,2 @@
-MD5 (samhain_signed-2.0.10.tar.gz) = 30fa821fdeb674b57aa7db0b66ed3af2
-SIZE (samhain_signed-2.0.10.tar.gz) = 1298443
+MD5 (samhain_signed-2.1.0.tar.gz) = 295eae6715c9c3e6af3dcafad52f761e
+SIZE (samhain_signed-2.1.0.tar.gz) = 1312114
diff --git a/security/samhain/pkg-plist b/security/samhain/pkg-plist
index 5da5f665f841..a152e8ff7cf3 100644
--- a/security/samhain/pkg-plist
+++ b/security/samhain/pkg-plist
@@ -2,6 +2,7 @@
%%YULE%%etc/yulerc.sample
%%YULE%%sbin/yule_setpwd
%%YULE%%sbin/yule
+%%YULE%%sbin/yulectl
%%YULE%%etc/rc.d/yule.sh.sample
%%YULE%%@unexec rmdir /var/lib/yule 2>/dev/null || true
%%SAMHAIN%%sbin/samhain