aboutsummaryrefslogtreecommitdiffstats
path: root/security/scamp
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-04-23 21:20:02 +0800
committerwxs <wxs@FreeBSD.org>2009-04-23 21:20:02 +0800
commitb0f01697b32647417eeac16fb71e5ad7ea2039c1 (patch)
tree10fd26a78d892a94516dbd4dd205edbb6b9a4b02 /security/scamp
parent3a35f54c905798bad20eec8789b567e0736f939f (diff)
downloadfreebsd-ports-gnome-b0f01697b32647417eeac16fb71e5ad7ea2039c1.tar.gz
freebsd-ports-gnome-b0f01697b32647417eeac16fb71e5ad7ea2039c1.tar.zst
freebsd-ports-gnome-b0f01697b32647417eeac16fb71e5ad7ea2039c1.zip
Download and install definition files for Clamav from the following sites:
sanesecurity.com malware.com.br msrbl.com clamav.securiteinfo.com WWW: https://sourceforge.net/projects/scamp/ PR: ports/133248 Submitted by: Gerard Seibert <gerard@seibercom.net>
Diffstat (limited to 'security/scamp')
-rw-r--r--security/scamp/Makefile58
-rw-r--r--security/scamp/distinfo3
-rw-r--r--security/scamp/files/default.sample38
-rw-r--r--security/scamp/files/pkg-message.in12
-rw-r--r--security/scamp/pkg-descr11
-rw-r--r--security/scamp/pkg-plist11
6 files changed, 133 insertions, 0 deletions
diff --git a/security/scamp/Makefile b/security/scamp/Makefile
new file mode 100644
index 000000000000..e2c5eb1ec9b0
--- /dev/null
+++ b/security/scamp/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: scamp
+# Date created: 31 March 2009
+# Whom: Gerard Seibert <gerard@seibercom.net>
+#
+# $FreeBSD$
+
+PORTNAME= scamp
+PORTVERSION= 5.2a
+CATEGORIES= security
+MASTER_SITES= SF
+
+MAINTAINER= gerard@seibercom.net
+COMMENT= Download & Install additional definition files for Clamav
+
+RUN_DEPENDS+= bash>=3.2.48_1:${PORTSDIR}/shells/bash3 \
+ clamav>=0.95.1:${PORTSDIR}/security/clamav \
+ gnupg>=2.0.11:${PORTSDIR}/security/gnupg \
+ rsync>=3.0.5:${PORTSDIR}/net/rsync
+
+.if exists (${LOCALBASE}/bin/wget) && ! exists (${LOCALBASE}/bin/curl)
+RUN_DEPENDS+= wget>=1.11.4:${PORTSDIR}/ftp/wget
+.else
+RUN_DEPENDS+= curl>=7.19.2:${PORTSDIR}/ftp/curl
+.endif
+
+NO_BUILD= yes
+
+SUB_FILES= pkg-message
+
+MAN1= scamp.1
+MANCOMPRESSED= no
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SIG_DB=$${SIG_DB:-""}|SIG_DB=$${SIG_DB:-"/var/db/clamav"}|g' ${WRKSRC}/${PORTNAME}.sh
+ @${REINPLACE_CMD} -e 's|CONFIG_DIR="/etc/scamp"|CONFIG_DIR="${PREFIX}/etc/scamp"|g' ${WRKSRC}/${PORTNAME}.sh
+
+post-install:
+ @if [ ! -d ${PREFIX}/etc/scamp ]; then \
+ ${MKDIR} ${PREFIX}/etc/scamp ; \
+ fi
+
+ @${INSTALL_DATA} ${FILESDIR}/default.sample ${PREFIX}/etc/scamp/
+ @if [ ! -f ${PREFIX}/etc/scamp/default ]; then \
+ ${CP} -p ${PREFIX}/etc/scamp/default.sample \
+ ${PREFIX}/etc/scamp/default ; \
+ fi
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTNAME}.sh ${PREFIX}/bin
+ cd ${WRKSRC} && ${INSTALL_MAN} scamp.1 ${MANPREFIX}/man/man1
+
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README CHANGE.LOG INSTALL Release.html ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/scamp/distinfo b/security/scamp/distinfo
new file mode 100644
index 000000000000..7623d96eb84b
--- /dev/null
+++ b/security/scamp/distinfo
@@ -0,0 +1,3 @@
+MD5 (scamp-5.2a.tar.gz) = 2e01f79b5731c79d42ff5d0f4c38427e
+SHA256 (scamp-5.2a.tar.gz) = 748a0a28b79187aec7836b4ca537671d15c799478dde0ab12ffc922b8c0ab0b0
+SIZE (scamp-5.2a.tar.gz) = 21060
diff --git a/security/scamp/files/default.sample b/security/scamp/files/default.sample
new file mode 100644
index 000000000000..de55e079d185
--- /dev/null
+++ b/security/scamp/files/default.sample
@@ -0,0 +1,38 @@
+# This is the /etc/scamp/default file.
+# Created April 18, 2009 @ 07:16:40
+
+SIG_DB=/var/db/clamav
+T_DIR=/var/db/clamav/tmp
+C_GROUP=clamav
+C_PID=/var/run/clamav/clamd.pid
+C_USER=clamav
+GET_LDB=1
+GET_MALWARE=1
+GET_MSRBL=1
+GET_SANE=1
+GET_SECURITE=1
+GET_WINNOW=1
+gpg_key_url=http://www.sanesecurity.net/publickey.gpg
+L_TYPE=1
+MK_LOG=0
+MSRBL=rsync://rsync.mirror.msrbl.com/msrbl/
+msrbl_Images=MSRBL-Images.hdb
+msrbl_SPAM=MSRBL-SPAM.ndb
+msrbl_SPAM_CR=MSRBL-SPAM-CR.ndb
+MSR_DIR=/var/db/clamav/tmp/msr
+MW_DIR=/var/db/clamav/tmp/malware
+MW_FILE=mbl.ndb
+MW_URL=http://www.malware.com.br/cgi/submit?action=list_clamav_ext
+RELOAD=1
+REST=0
+SANE=rsync://rsync.sanesecurity.net/sanesecurity
+SANE_DB=/var/db/clamav/tmp/sane
+SI_DIR=/var/db/clamav/tmp/securite
+SI_URL1=http://clamav.securiteinfo.com/vx.hdb.gz
+SI_URL2=http://clamav.securiteinfo.com/honeynet.hdb.gz
+SI_URL3=http://clamav.securiteinfo.com/securiteinfo.hdb.gz
+SI_URL4=http://clamav.securiteinfo.com/antispam.ndb.gz
+SI_URL=$SI_URL1" "$SI_URL2" "$SI_URL3" "$SI_URL4
+SYS_LOG=1
+WPC=1
+W_SUM=1
diff --git a/security/scamp/files/pkg-message.in b/security/scamp/files/pkg-message.in
new file mode 100644
index 000000000000..b7e67616f2f5
--- /dev/null
+++ b/security/scamp/files/pkg-message.in
@@ -0,0 +1,12 @@
+
+
+ **************************************************
+ * *
+ * To configure this script prior to running it *
+ * the first time, please use the [-c] command *
+ * line option; i.e.: scamp.sh -c *
+ * *
+ * This will create a new config file and exit. *
+ * *
+ **************************************************
+
diff --git a/security/scamp/pkg-descr b/security/scamp/pkg-descr
new file mode 100644
index 000000000000..8c155a4e4d77
--- /dev/null
+++ b/security/scamp/pkg-descr
@@ -0,0 +1,11 @@
+This Bash script will download and install definition files for Clamav from the
+following sites:
+
+sanesecurity.com
+malware.com.br
+msrbl.com
+clamav.securiteinfo.com
+
+Site Address:
+
+WWW: https://sourceforge.net/projects/scamp/
diff --git a/security/scamp/pkg-plist b/security/scamp/pkg-plist
new file mode 100644
index 000000000000..a2101eeaaac4
--- /dev/null
+++ b/security/scamp/pkg-plist
@@ -0,0 +1,11 @@
+bin/scamp.sh
+%%PORTDOCS%%%%DOCSDIR%%/CHANGE.LOG
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/Release.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec if cmp -s %D/etc/scamp/default.sample %D/etc/scamp/default; then rm -f %D/etc/scamp/default; fi
+etc/scamp/default.sample
+@exec if [ ! -f %D/etc/scamp/default ] ; then cp -p %D/%F %B/default; fi
+@exec mkdir -p %D/etc/scamp
+@dirrmtry etc/scamp