aboutsummaryrefslogtreecommitdiffstats
path: root/security/scanhill
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2007-06-25 20:34:07 +0800
committergarga <garga@FreeBSD.org>2007-06-25 20:34:07 +0800
commit613cb7c9804d77a2c38d4cb2af452d14225ffb55 (patch)
treef5d441f7a622fb1c108a1079608647d8b3e0b4c5 /security/scanhill
parentf3cf96e5cac9e9b99ff022c2c30540046e1f0ba4 (diff)
downloadfreebsd-ports-gnome-613cb7c9804d77a2c38d4cb2af452d14225ffb55.tar.gz
freebsd-ports-gnome-613cb7c9804d77a2c38d4cb2af452d14225ffb55.tar.zst
freebsd-ports-gnome-613cb7c9804d77a2c38d4cb2af452d14225ffb55.zip
Scanhill is a Microsoft Messenger Protocol Sniffer. Currently it can only
intercept Instant Text Messaging. Optionally, intercepted text messages can be stored onto an RDMBS (Only mySQL is supported for now). Given that mySQL is used, stored instant messages can be read through a browser interface that is written in PHP language. Please see the INSTALL.txt file for instructions on how to install, configure and run EnderUNIX scanhill. WWW: http://www.enderunix.org/scanhill/
Diffstat (limited to 'security/scanhill')
-rw-r--r--security/scanhill/Makefile45
-rw-r--r--security/scanhill/distinfo3
-rw-r--r--security/scanhill/pkg-descr8
-rw-r--r--security/scanhill/pkg-plist5
4 files changed, 61 insertions, 0 deletions
diff --git a/security/scanhill/Makefile b/security/scanhill/Makefile
new file mode 100644
index 000000000000..7fef4b4bb442
--- /dev/null
+++ b/security/scanhill/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: scanhill
+# Date created: 2007-06-18
+# Whom: garga
+#
+# $FreeBSD$
+#
+
+PORTNAME= scanhill
+DISTVERSION= 0.5-p1
+CATEGORIES= security net-im
+MASTER_SITES= http://www.enderunix.org/scanhill/
+
+MAINTAINER= garga@FreeBSD.org
+COMMENT= Microsoft Messenger Protocol Sniffer
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+GNU_CONFIGURE= yes
+USE_ICONV= yes
+
+PORTDOCS= README.txt INSTALL.txt mysql.sql
+
+OPTIONS= MYSQL "Enable MySQL support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MYSQL)
+CONFIGURE_ARGS+= --enable-mysql
+USE_MYSQL= yes
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/scanhill ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/scanhill.conf ${PREFIX}/etc/scanhill.conf-dist
+.if !exists(${PREFIX}/etc/scanhill.conf)
+ ${INSTALL_DATA} ${WRKSRC}/scanhill.conf ${PREFIX}/etc/
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/scanhill/distinfo b/security/scanhill/distinfo
new file mode 100644
index 000000000000..58ec2ccfa3f3
--- /dev/null
+++ b/security/scanhill/distinfo
@@ -0,0 +1,3 @@
+MD5 (scanhill-0.5-p1.tar.gz) = 44fe6932e275c078097ea3234fdead67
+SHA256 (scanhill-0.5-p1.tar.gz) = 45e74b809301ac017877fbbeeef107a6baa6c9e881f7fe8c40be996a85e2b195
+SIZE (scanhill-0.5-p1.tar.gz) = 28658
diff --git a/security/scanhill/pkg-descr b/security/scanhill/pkg-descr
new file mode 100644
index 000000000000..d7002fd5257f
--- /dev/null
+++ b/security/scanhill/pkg-descr
@@ -0,0 +1,8 @@
+Scanhill is a Microsoft Messenger Protocol Sniffer. Currently it can only
+intercept Instant Text Messaging. Optionally, intercepted text messages can be
+stored onto an RDMBS (Only mySQL is supported for now). Given that mySQL is
+used, stored instant messages can be read through a browser interface that is
+written in PHP language. Please see the INSTALL.txt file for instructions on
+how to install, configure and run EnderUNIX scanhill.
+
+WWW: http://www.enderunix.org/scanhill/
diff --git a/security/scanhill/pkg-plist b/security/scanhill/pkg-plist
new file mode 100644
index 000000000000..9c48be1b2ed4
--- /dev/null
+++ b/security/scanhill/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+bin/scanhill
+@unexec if cmp -s %D/etc/scanhill.conf-dist %D/etc/scanhill.conf; then rm -f %D/etc/scanhill.conf; fi
+etc/scanhill.conf-dist
+@exec [ -f %B/scanhill.conf ] || cp -f %B/%f %B/scanhill.conf