aboutsummaryrefslogtreecommitdiffstats
path: root/security/skipfish
diff options
context:
space:
mode:
authorniels <niels@FreeBSD.org>2010-04-12 05:16:27 +0800
committerniels <niels@FreeBSD.org>2010-04-12 05:16:27 +0800
commit436879ea9548f685ce9e27de1ffdbb9637d7b076 (patch)
tree55d9771a7057e97a622822a67ae2dc71df91b8b8 /security/skipfish
parentb5430bd42a1699c079cee00f22fd84bd8eb470cc (diff)
downloadfreebsd-ports-gnome-436879ea9548f685ce9e27de1ffdbb9637d7b076.tar.gz
freebsd-ports-gnome-436879ea9548f685ce9e27de1ffdbb9637d7b076.tar.zst
freebsd-ports-gnome-436879ea9548f685ce9e27de1ffdbb9637d7b076.zip
Upgraded to version 1.30b
Submitted by: Ryan Steinmetz (maintainer) Approved by: itetcu (mentor)
Diffstat (limited to 'security/skipfish')
-rw-r--r--security/skipfish/Makefile2
-rw-r--r--security/skipfish/distinfo6
-rw-r--r--security/skipfish/files/patch-Makefile30
-rw-r--r--security/skipfish/files/patch-ab11
-rw-r--r--security/skipfish/files/patch-report.c (renamed from security/skipfish/files/patch-ac)4
5 files changed, 36 insertions, 17 deletions
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index 40908fbc8123..a284ca4399fc 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= skipfish
-PORTVERSION= 1.29b
+PORTVERSION= 1.30b
CATEGORIES= security www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
diff --git a/security/skipfish/distinfo b/security/skipfish/distinfo
index 14b806ef34f8..492d74c7ba8c 100644
--- a/security/skipfish/distinfo
+++ b/security/skipfish/distinfo
@@ -1,3 +1,3 @@
-MD5 (skipfish-1.29b.tgz) = 84544ad46472d1f5eb22987aaa06333e
-SHA256 (skipfish-1.29b.tgz) = d11f7a5f84626a4a880eb4a245b559dd765819c9943bb5f8eed041cc0d22377d
-SIZE (skipfish-1.29b.tgz) = 175977
+MD5 (skipfish-1.30b.tgz) = 38860dc297b340422c048e9ab7ac9353
+SHA256 (skipfish-1.30b.tgz) = 43f5d9b15dfc99ceff549b063f9ea2576dc884d2a604a3ae2217c6ac89127be8
+SIZE (skipfish-1.30b.tgz) = 176042
diff --git a/security/skipfish/files/patch-Makefile b/security/skipfish/files/patch-Makefile
new file mode 100644
index 000000000000..9b8fe477c0db
--- /dev/null
+++ b/security/skipfish/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- ./Makefile.orig 2010-03-30 17:53:01.000000000 +0200
++++ ./Makefile 2010-04-11 19:05:39.000000000 +0200
+@@ -30,7 +30,7 @@
+ CFLAGS_DBG = -DLOG_STDERR=1 -DDEBUG_ALLOCATOR=1 $(CFLAGS_GEN)
+ CFLAGS_OPT = -O3 -Wno-format $(CFLAGS_GEN)
+
+-LDFLAGS += -L/usr/local/lib/ -L/opt/local/lib
++LDFLAGS += -L$(LOCALBASE)/lib/
+ LIBS += -lcrypto -lssl -lidn -lz
+
+ all: $(PROGNAME)
+@@ -38,12 +38,12 @@
+ $(PROGNAME): $(PROGNAME).c $(OBJFILES) $(INCFILES)
+ $(CC) $(LDFLAGS) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS_OPT) \
+ $(OBJFILES) $(LIBS)
+- @echo
+- @echo "See dictionaries/README-FIRST to pick a dictionary for the tool."
+- @echo
+- @echo "Having problems with your scans? Be sure to visit:"
+- @echo "http://code.google.com/p/skipfish/wiki/KnownIssues"
+- @echo
++# @echo
++# @echo "See dictionaries/README-FIRST to pick a dictionary for the tool."
++# @echo
++# @echo "Having problems with your scans? Be sure to visit:"
++# @echo "http://code.google.com/p/skipfish/wiki/KnownIssues"
++# @echo
+
+ debug: $(PROGNAME).c $(OBJFILES) $(INCFILES)
+ $(CC) $(LDFLAGS) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS_DBG) \
diff --git a/security/skipfish/files/patch-ab b/security/skipfish/files/patch-ab
deleted file mode 100644
index 5d1305bdc724..000000000000
--- a/security/skipfish/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- analysis.c.orig 2010-03-25 20:26:41.000000000 +0100
-+++ analysis.c 2010-03-25 01:47:35.000000000 +0100
-@@ -394,7 +394,7 @@
- static u8 tm_prefix[8];
-
- if (!tm_prefix[0])
-- sprintf((char*)tm_prefix, "%lu", time(0) / 100000);
-+ sprintf((char*)tm_prefix, "%lu",(long unsigned int) (time(0) / 100000));
-
- /* Unix time is not a valid token. */
-
diff --git a/security/skipfish/files/patch-ac b/security/skipfish/files/patch-report.c
index 9aa4278589ab..1c2ed9d002a7 100644
--- a/security/skipfish/files/patch-ac
+++ b/security/skipfish/files/patch-report.c
@@ -1,5 +1,5 @@
---- report.c.orig 2010-04-03 19:23:47.000000000 +0200
-+++ report.c 2010-04-03 19:40:28.000000000 +0200
+--- ./report.c.orig 2010-04-09 00:36:30.000000000 +0200
++++ ./report.c 2010-04-11 19:05:39.000000000 +0200
@@ -741,7 +741,7 @@
static void copy_static_code(u8* out_dir) {
struct dirent** d;