aboutsummaryrefslogtreecommitdiffstats
path: root/security/snort
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-09-06 00:55:34 +0800
committerzi <zi@FreeBSD.org>2013-09-06 00:55:34 +0800
commitf3138bcc9bdf4f54406574ccb2cdab80b4833c87 (patch)
treea1dc2ff8aad522f33e44158de2f4c9415b09bf0b /security/snort
parent92cdf6e1ec1696b58367c18f230d8dfc38a706ab (diff)
downloadfreebsd-ports-gnome-f3138bcc9bdf4f54406574ccb2cdab80b4833c87.tar.gz
freebsd-ports-gnome-f3138bcc9bdf4f54406574ccb2cdab80b4833c87.tar.zst
freebsd-ports-gnome-f3138bcc9bdf4f54406574ccb2cdab80b4833c87.zip
- Add OPTION to enable non-Ethernet decoders
Requested by: Andrew Nichols <andrew@quadrant.net>
Diffstat (limited to 'security/snort')
-rw-r--r--security/snort/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 05bac250b569..a8b41b57fb25 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= daq>=2.0.0:${PORTSDIR}/net/daq \
OPTIONS_DEFINE= IPV6 MPLS GRE TARGETBASED ZLIB NORMALIZER REACT \
PERFPROFILE FLEXRESP3 LRGPCAP SNORTSAM SOURCEFIRE \
- DBGSNORT BARNYARD PULLEDPORK
+ DBGSNORT BARNYARD PULLEDPORK NONETHER
OPTIONS_DEFAULT=IPV6 MPLS GRE ZLIB NORMALIZER REACT PERFPROFILE \
FLEXRESP3 SOURCEFIRE TARGETBASED PULLEDPORK \
BARNYARD
@@ -31,6 +31,7 @@ OPTIONS_DEFAULT=IPV6 MPLS GRE ZLIB NORMALIZER REACT PERFPROFILE \
GRE_DESC= Enable GRE support
TARGETBASED_DESC= Enable targetbased support
ZLIB_DESC= Enable GZIP support
+NONETHER_DESC= Enable non-Ethernet Decoders
NORMALIZER_DESC= Enable normalizer
REACT_DESC= Enable react
PERFPROFILE_DESC= Enable performance profiling
@@ -113,6 +114,10 @@ CONFIGURE_ARGS+=--disable-ipv6
CONFIGURE_ARGS+=--disable-gre
.endif
+.if ${PORT_OPTIONS:MNONETHER}
+CONFIGURE_ARGS+=--enable-non-ether-decoders
+.endif
+
.if empty(PORT_OPTIONS:MMPLS)
CONFIGURE_ARGS+=--disable-mpls
.endif