aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh/Makefile
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1996-07-16 08:33:19 +0800
committerache <ache@FreeBSD.org>1996-07-16 08:33:19 +0800
commit973d8e269463d649e1e1ce152e6296abeb278d48 (patch)
tree1f138bf0309d162ef81dbf165a69174e008ed7d0 /security/ssh/Makefile
parentaae555e01aa754bf2df823ce7c871d37d581bcc5 (diff)
downloadfreebsd-ports-gnome-973d8e269463d649e1e1ce152e6296abeb278d48.tar.gz
freebsd-ports-gnome-973d8e269463d649e1e1ce152e6296abeb278d48.tar.zst
freebsd-ports-gnome-973d8e269463d649e1e1ce152e6296abeb278d48.zip
Upgrade to 1.2.14.1
Misc bugfixes
Diffstat (limited to 'security/ssh/Makefile')
-rw-r--r--security/ssh/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index 74855bb9b598..ae9baceed5a6 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -1,20 +1,26 @@
# New ports collection makefile for: ssh
-# Version required: 1.2.14
+# Version required: 1.2.14.1
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.26 1996/06/15 17:50:17 jkh Exp $
+# $Id: Makefile,v 1.27 1996/06/20 14:11:17 ache Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
#
-DISTNAME= ssh-1.2.14
+DISTNAME= ssh-1.2.14.1
CATEGORIES= security net
-MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
+MASTER_SITES= http://ssh.fi/ \
+ ftp://ftp.relcom.ru/unix/crypto/
+#MASTER_SITES= ftp://ftp.cs.hut.fi/pub/ssh/
MAINTAINER= torstenb@FreeBSD.ORG
+# WARNING: you need libz 1.0.3 or above, previous versions have a bug
+
+LIB_DEPENDS= z\\.1\\.0:${PORTSDIR}/devel/libz
+
# You can set USA_RESIDENT appropriately in /etc/make.conf if this bugs you..
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
@@ -33,7 +39,7 @@ IS_INTERACTIVE= YES
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-etcdir=${PREFIX}/etc
+CONFIGURE_ARGS+= --with-etcdir=${PREFIX}/etc --no-recursion
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
CONFIGURE_ARGS+= --with-rsaref
@@ -85,6 +91,8 @@ post-install:
${PREFIX}/man/man1/ssh-agent.1 ${PREFIX}/man/man1/ssh-keygen.1 \
${PREFIX}/man/man1/ssh.1 ${PREFIX}/man/man8/sshd.8 \
${PREFIX}/man/man1/make-ssh-known-hosts.1
+ rm ${PREFIX}/man/man1/slogin.1
+ ln -fs ${PREFIX}/man/man1/ssh.1.gz ${PREFIX}/man/man1/slogin.1.gz
@if [ ! -f ${PREFIX}/etc/rc.d/sshd.sh ]; then \
echo "Installing ${PREFIX}/etc/rc.d/sshd.sh startup file."; \
echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/sshd.sh; \
@@ -97,10 +105,10 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_PERL) && ${USE_PERL} == YES || \
- exists(${PREFIX}/bin/perl5.002) && \
+ exists(${PREFIX}/bin/perl5.003) && \
(!defined(USE_PERL) || ${USE_PERL} != NO)
-BUILD_DEPENDS+= perl5.002:${PORTSDIR}/lang/perl5
-CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.002
+BUILD_DEPENDS+= perl5.003:${PORTSDIR}/lang/perl5
+CONFIGURE_ENV+= PERL=${PREFIX}/bin/perl5.003
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
.endif