aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh/Makefile
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1995-10-11 01:02:24 +0800
committerache <ache@FreeBSD.org>1995-10-11 01:02:24 +0800
commitf32473ec68e01e6e63385f144dd133d992f81153 (patch)
tree6991b154b16ddb2bf6deb5adf58818bfbc8acc88 /security/ssh/Makefile
parente601b42639dad079f04844eaa1cfeb4431da8a9c (diff)
downloadfreebsd-ports-gnome-f32473ec68e01e6e63385f144dd133d992f81153.tar.gz
freebsd-ports-gnome-f32473ec68e01e6e63385f144dd133d992f81153.tar.zst
freebsd-ports-gnome-f32473ec68e01e6e63385f144dd133d992f81153.zip
Fix tcp_wrapper support
Diffstat (limited to 'security/ssh/Makefile')
-rw-r--r--security/ssh/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index 1f95fb625601..3dc9d363c90a 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.1.1.1 1995/10/07 01:19:27 torstenb Exp $
+# $Id: Makefile,v 1.2 1995/10/07 13:08:35 torstenb Exp $
#
DISTNAME= ssh-1.2.10
@@ -40,9 +40,10 @@ CONFIGURE_ARGS+= --with-rsaref
CONFIGURE_ARGS+= --with-socks
.endif
-# Include tcp-wrapper support and identd support
-# Warning: untested !
-.if defined(USE_TCPWRAP_AND_IDENTD) && ${USE_TCPWRAP_AND_IDENTD} == YES
+# Include tcp-wrapper support (call remote identd)
+.if defined(USE_TCPWRAP) && ${USE_TCPWRAP} == YES
+CONFIGURE_ENV= LDFLAGS=-L${PREFIX}/lib CFLAGS="${CFLAGS} -I${PREFIX}/include"
+BUILD_DEPENDS+= safe_finger:${PORTSDIR}/security/tcp_wrapper
CONFIGURE_ARGS+= --with-libwrap
.endif