aboutsummaryrefslogtreecommitdiffstats
path: root/security/stunnel/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2009-11-13 18:58:57 +0800
committerroam <roam@FreeBSD.org>2009-11-13 18:58:57 +0800
commit611440be791f5086108d02ac144eb87342f7e0e7 (patch)
tree0d6577dc8e9697f13a9415baa5f2b5ba1b58299b /security/stunnel/Makefile
parent8736607b86dcbaebc47879f53643208935eaa10c (diff)
downloadfreebsd-ports-gnome-611440be791f5086108d02ac144eb87342f7e0e7.tar.gz
freebsd-ports-gnome-611440be791f5086108d02ac144eb87342f7e0e7.tar.zst
freebsd-ports-gnome-611440be791f5086108d02ac144eb87342f7e0e7.zip
Update stunnel to 4.28, including a patch for older SSL versions.
Add two new configurable options to disable libwrap support (almost as in the PR, but not quite) and enable Diffie-Hellman key exchange. PR: 139147 (only the libwrap support, but missing -lwrap) Submitted by: Jim Riggs <ports@christianserving.org>
Diffstat (limited to 'security/stunnel/Makefile')
-rw-r--r--security/stunnel/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index ce93d8426ca2..0347439f9014 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.27
+PORTVERSION= 4.28
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
ftp://opensores.thebunker.net/pub/mirrors/stunnel/download/stunnel/src/
+PATCH_SITES= ftp://stunnel.mirt.net/stunnel/
+PATCHFILES= no_ticket.patch
+
MAINTAINER= roam@FreeBSD.org
COMMENT= SSL encryption wrapper for standard network daemons
@@ -33,12 +36,29 @@ PEM_DIR?= ${PREFIX}/etc
OPTIONS= FORK "use the fork(3) threading model" off \
PTHREAD "use the pthread(3) threading model (default)" on \
UCONTEXT "use the ucontext(3) threading model" off \
- IPV6 "enable IPv6 support" off
+ DH "use Diffie-Hellman key negotiation" off \
+ IPV6 "enable IPv6 support" off \
+ LIBWRAP "use TCP wrappers" on
.include <bsd.port.pre.mk>
+.if defined(WITH_DH)
+CONFIGURE_ARGS+= --enable-dh
+.else
+CONFIGURE_ARGS+= --disable-dh
+.endif
+
.if defined(WITH_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.if defined(WITH_LIBWRAP)
+CONFIGURE_ARGS+= --enable-libwrap
+LDFLAGS+= -lwrap
+.else
+CONFIGURE_ARGS+= --disable-libwrap
.endif
.if defined(WITH_UCONTEXT) && defined(WITH_FORK) || defined(WITH_UCONTEXT) && defined(WITH_PTHREAD) || defined(WITH_FORK) && defined(WITH_PTHREAD)