aboutsummaryrefslogtreecommitdiffstats
path: root/security/sudo
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2009-06-12 08:46:49 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2009-06-12 08:46:49 +0800
commit4c014770393b67b5925196af22aa2552bf6d6e2e (patch)
treeabb9b5e9d21301dc1602b05de92a3f40a05ff2a4 /security/sudo
parent2ad7f6fe7230f75436dd73df6a1c52ebf7c7d745 (diff)
downloadfreebsd-ports-gnome-4c014770393b67b5925196af22aa2552bf6d6e2e.tar.gz
freebsd-ports-gnome-4c014770393b67b5925196af22aa2552bf6d6e2e.tar.zst
freebsd-ports-gnome-4c014770393b67b5925196af22aa2552bf6d6e2e.zip
Add OPTIONS for WITH_DISABLE_ROOT_SUDO, WITH_DISABLE_AUTH, and
WITH_NOARGS_SHELL Submitted by: Scott Fultz
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 77c2a28c26e8..114e6488d715 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -34,7 +34,10 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
OPTIONS= LDAP "With LDAP support" off \
INSULTS "With all insults" off \
- SHELL_SETS_HOME "Set HOME env to target user in shell mode" off
+ SHELL_SETS_HOME "Set HOME env to target user in shell mode" off \
+ DISABLE_ROOT_SUDO "Disable root sudo" off \
+ DISABLE_AUTH "Disable authentication" off \
+ NOARGS_SHELL "Enable no arguments shell" off
.include <bsd.port.pre.mk>
@@ -62,6 +65,18 @@ PLIST_SUB= LDAP="@comment "
CONFIGURE_ARGS+=--enable-shell-sets-home
.endif
+.if defined(WITH_DISABLE_ROOT_SUDO)
+CONFIGURE_ARGS+=--disable-root-sudo
+.endif
+
+.if defined(WITH_DISABLE_AUTH)
+CONFIGURE_ARGS+=--disable-authentication
+.endif
+
+.if defined(WITH_NOARGS_SHELL)
+CONFIGURE_ARGS+=--enable-noargs-shell
+.endif
+
MAN5= sudoers.5
MAN8= sudo.8 visudo.8
MLINKS= sudo.8 sudoedit.8