aboutsummaryrefslogtreecommitdiffstats
path: root/security/sudo
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /security/sudo
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index b831a273d0ac..7cb03a5a57ad 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -65,8 +65,8 @@ CONFIGURE_ARGS+= --with-logfac=${LOGFAC}
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
+CFLAGS+= -I${LOCALBASE}/include
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls