aboutsummaryrefslogtreecommitdiffstats
path: root/security/termlog
diff options
context:
space:
mode:
authorcsjp <csjp@FreeBSD.org>2005-09-25 23:02:12 +0800
committercsjp <csjp@FreeBSD.org>2005-09-25 23:02:12 +0800
commit15aa42123c89f3e448306505aba7fdb6af5035d1 (patch)
tree3c70f295828b7dc3c263d1fd9da27dc4e4c3f8c2 /security/termlog
parentd7937abc045e5045a37b72ea6db14b6984f71a2e (diff)
downloadfreebsd-ports-gnome-15aa42123c89f3e448306505aba7fdb6af5035d1.tar.gz
freebsd-ports-gnome-15aa42123c89f3e448306505aba7fdb6af5035d1.tar.zst
freebsd-ports-gnome-15aa42123c89f3e448306505aba7fdb6af5035d1.zip
-Remove MANCOMPRESSED macro as it's not required
-Introduce do-install target which will use INSTALL_MAN and INSTALL_PROGRAM macros to install the files. This should fix packet build failures. Approved by: kris
Diffstat (limited to 'security/termlog')
-rw-r--r--security/termlog/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/termlog/Makefile b/security/termlog/Makefile
index 1d68cda3008a..8f13b71d110b 100644
--- a/security/termlog/Makefile
+++ b/security/termlog/Makefile
@@ -14,8 +14,13 @@ MASTER_SITE_SUBDIR= termlog
MAINTAINER= csjp@FreeBSD.org
COMMENT= Monitor or log multiple system terminals synchronously
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
MAN1= termlog.1
-MANCOMPRESSED= yes
PLIST_FILES= bin/termlog
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/termlog ${PREFIX}/bin/termlog
+ ${INSTALL_MAN} ${WRKSRC}/termlog.1 ${MANPREFIX}/man/man1/termlog.1
+
.include <bsd.port.mk>