aboutsummaryrefslogtreecommitdiffstats
path: root/security/tor
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-09-24 03:58:35 +0800
committerBrendan Fabeny <bf@FreeBSD.org>2011-09-24 03:58:35 +0800
commit37da0d8f4dd8c4d5fc0c51fcd26c161fccee6ec5 (patch)
tree28341e15779bf52302d1a8b3e60c6de22cf2994c /security/tor
parent2601be140b7225aed7b59bccc8aefa3b7fd1a684 (diff)
downloadfreebsd-ports-gnome-37da0d8f4dd8c4d5fc0c51fcd26c161fccee6ec5.tar.gz
freebsd-ports-gnome-37da0d8f4dd8c4d5fc0c51fcd26c161fccee6ec5.tar.zst
freebsd-ports-gnome-37da0d8f4dd8c4d5fc0c51fcd26c161fccee6ec5.zip
add an option to use GNU make for those who wish
to perform parallel builds[1]; add a few mirrors to tor-devel Requested by: h.h. [1]
Diffstat (limited to 'security/tor')
-rw-r--r--security/tor/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 90c1b43aad28..0de7cd1aaa78 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tor
DISTVERSION= 0.2.2.33
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= https://www.torproject.org/dist/ \
ftp://ftp.bit.nl/mirror/tor/ \
@@ -53,9 +54,8 @@ CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" \
TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
TOR_LIBEVENT_LIBS="-levent-2.0"
-MAKE_JOBS_UNSAFE= yes
-
OPTIONS= BUFFREELISTS "freelists for buffer RAM" on \
+ GMAKE "parallel build safety via GNU make" off \
INSTR_DOWNLOADS "instrument downloads for analysis" off \
TCMALLOC "use the tcmalloc memory allocation library" off \
THREADS "multi-threading support" on \
@@ -74,6 +74,12 @@ MAN1= tor.1 tor-resolve.1 torify.1 tor-gencert.1
.include <bsd.port.pre.mk>
+.if defined(WITH_GMAKE)
+USE_GMAKE= yes
+.else
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ( (${OSVERSION} >= 703100 && ${OSVERSION} < 800000) || \
(${OSVERSION} >= 800500 && ${OSVERSION} < 900000) || \
(${OSVERSION} >= 900003) ) && !defined(USE_GCC) && empty(CC:M*gcc4*)