aboutsummaryrefslogtreecommitdiffstats
path: root/security/tthsum
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-10-05 00:44:54 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-10-05 00:44:54 +0800
commit6f3b1b9875bcb872499607c21ba91556f87ebc34 (patch)
tree062df87d0ffdbf1e18f63103ca624e7c03ba0123 /security/tthsum
parentb5a43a23094d55deee6a89529598ccf6818998bd (diff)
downloadfreebsd-ports-gnome-6f3b1b9875bcb872499607c21ba91556f87ebc34.tar.gz
freebsd-ports-gnome-6f3b1b9875bcb872499607c21ba91556f87ebc34.tar.zst
freebsd-ports-gnome-6f3b1b9875bcb872499607c21ba91556f87ebc34.zip
- Update to 1.2.1 [1]
- Update WWW [1] Changelog: tthsum-1.2.1 [2009-12-29] (wdoekes) * Minor code and build system cleanup. tthsum-1.2.0 [2009-05-29] (wdoekes) * Changed -p output to print percentages instead of MiB counts. * Base32 decoding errors did not generate a valid error message. (Error code 0 conflicted with SUCCESS.) * Fixed that ctrlesctostr accepted strange BASE36 escape sequences. * Made getopt for Windows more compatible with POSIX getopt. * Fixed that including the tthsum specific texts.c is optional. * Changed some header inclusions to be more compliant with C specs and made the source a bit more strict (ANSI C compatible, C++ compatible). * Added a test suite to detect stupid bugs at compile time. (Like the next bug.) * Endianness was not properly detected on various architectures (see debian bug 517619; thanks Alan Curry <pacman> for reporting). * Standardized UTF8 functions to behave as specified on Windows. * Corrected the need for a double EOF when reading from stdin. * Changed license from GPLv2 to GPLv3. Updated help texts (suggesting gmake on non-Linuxen, for instance). * Removed a bit of overhead on big endian platforms.
Diffstat (limited to 'security/tthsum')
-rw-r--r--security/tthsum/Makefile32
-rw-r--r--security/tthsum/distinfo6
-rw-r--r--security/tthsum/files/patch-Makefile40
-rw-r--r--security/tthsum/pkg-descr4
4 files changed, 51 insertions, 31 deletions
diff --git a/security/tthsum/Makefile b/security/tthsum/Makefile
index 10ca3fa5a6b8..8be11991f8db 100644
--- a/security/tthsum/Makefile
+++ b/security/tthsum/Makefile
@@ -6,40 +6,20 @@
#
PORTNAME= tthsum
-PORTVERSION= 1.1.0
+PORTVERSION= 1.2.1
CATEGORIES= security
-MASTER_SITES= CRITICAL
+MASTER_SITES= http://tthsum.devs.nu/pkg/ \
+ CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command-line utility for generating and checking TTH message digests
USE_GMAKE= yes
-MAKE_JOBS_SAFE= yes
+MANCOMPRESSED= yes
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
+MAKE_JOBS_SAFE= yes
-PORTDOCS= Changelog.txt
-PLIST_FILES= bin/tthsum
MAN1= tthsum.1
-
-post-patch:
- @${REINPLACE_CMD} -E '/^(CC|CFLAGS)/d' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,g' \
- ${WRKSRC}/base32.c \
- ${WRKSRC}/read.c \
- ${WRKSRC}/utf8.c
- @${REINPLACE_CMD} '/stdio.h/H; /stdio\.h/{ p; s/#include <stdio.h>/#define O_LARGEFILE 0/;}' \
- ${WRKSRC}/read.c \
- ${WRKSRC}/thex.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/obj-${ARCH}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+PLIST_FILES= bin/tthsum
.include <bsd.port.mk>
diff --git a/security/tthsum/distinfo b/security/tthsum/distinfo
index 0fdbaf367bc0..35aed0f5276b 100644
--- a/security/tthsum/distinfo
+++ b/security/tthsum/distinfo
@@ -1,3 +1,3 @@
-MD5 (tthsum-1.1.0.tar.gz) = 40c01622446865e0bfea1586caf6aa32
-SHA256 (tthsum-1.1.0.tar.gz) = 76458abea27d119f501792875e26a8dc5dfb18a49953752f3be9860437cb9d51
-SIZE (tthsum-1.1.0.tar.gz) = 39917
+MD5 (tthsum-1.2.1.tar.gz) = 0bf6d47f3f8b942d0d2b73397551cbb4
+SHA256 (tthsum-1.2.1.tar.gz) = ad3497840c3f9941c3d175ac21b3718d0c88cc63eba59fd90f4d22de59870281
+SIZE (tthsum-1.2.1.tar.gz) = 69475
diff --git a/security/tthsum/files/patch-Makefile b/security/tthsum/files/patch-Makefile
new file mode 100644
index 000000000000..fe60f1e78639
--- /dev/null
+++ b/security/tthsum/files/patch-Makefile
@@ -0,0 +1,40 @@
+--- ./Makefile.orig 2009-12-29 22:24:48.000000000 +0100
++++ ./Makefile 2010-10-04 18:30:51.000000000 +0200
+@@ -2,7 +2,7 @@
+ #
+ # Makefile for GNU Make.
+
+-.PHONY: all clean dists install manual tthsum uninstall test runtest
++.PHONY: all clean dists install manual tthsum uninstall
+
+ #ifeq ($(ARCH),)
+ # ARCH = $(shell uname -m)
+@@ -16,15 +16,13 @@
+
+ ifeq ($(DEBUG),)
+ CPPFLAGS += -DNDEBUG
+- CFLAGS += -march=native -O3 #-fno-stack-protector
+- LDFLAGS += -march=native -O3
+ else
+ CPPFLAGS += -DDEBUG
+ CFLAGS += -g #-pg
+ LDFLAGS += -g #-pg
+ endif
+
+-CC = gcc
++CC ?= gcc
+ GZIP = gzip -9 -c
+ RM = rm -rf
+
+@@ -46,9 +44,9 @@
+ TSTENTRY = $(BINS)/test.o
+
+
+-all: tthsum manual test runtest
++all: tthsum manual
+
+-install: tthsum manual test runtest
++install: tthsum manual
+ install -d $(BIN) $(MAN)/man1
+ install $(BINS)/tthsum $(BIN)
+ install -m644 $(SHARES)/tthsum.1.gz $(MAN)/man1
diff --git a/security/tthsum/pkg-descr b/security/tthsum/pkg-descr
index 6664affde24f..19ea36cb6ce8 100644
--- a/security/tthsum/pkg-descr
+++ b/security/tthsum/pkg-descr
@@ -1,4 +1,4 @@
-Tthsum generates and checks TTH checksums (root of the THEX hash tree).
+tthsum generates and checks TTH checksums (root of the THEX hash tree).
The Merkle Hash Tree is a hash construct that exhibits desirable properties for
verifying the integrity of files and file subranges in an incremental or
@@ -7,4 +7,4 @@ out-of-order fashion.
The tool uses the Tiger hash algorithm for both the internal and the leaf
nodes, and has an interface identical to md5sum.
-WWW: http://freshmeat.net/projects/tthsum/
+WWW: http://tthsum.devs.nu/