aboutsummaryrefslogtreecommitdiffstats
path: root/security/umit/Makefile
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-08-31 21:44:28 +0800
committerwg <wg@FreeBSD.org>2014-08-31 21:44:28 +0800
commit420344564383d5e82af6fdbe9078743ad39f04a9 (patch)
treecb634075e24d85f01d39671e72491fdafaa5c9df /security/umit/Makefile
parentc6ecc0f77d271bec26e4a9adced7d0260d3fb891 (diff)
downloadfreebsd-ports-gnome-420344564383d5e82af6fdbe9078743ad39f04a9.tar.gz
freebsd-ports-gnome-420344564383d5e82af6fdbe9078743ad39f04a9.tar.zst
freebsd-ports-gnome-420344564383d5e82af6fdbe9078743ad39f04a9.zip
security/umit: support stage
- Add DOCS option - USES python - Simplify comment - Add desktop entry PR: 193167 Submitted by: Ports Fury
Diffstat (limited to 'security/umit/Makefile')
-rw-r--r--security/umit/Makefile43
1 files changed, 29 insertions, 14 deletions
diff --git a/security/umit/Makefile b/security/umit/Makefile
index dd7304d0bebb..679386611f99 100644
--- a/security/umit/Makefile
+++ b/security/umit/Makefile
@@ -3,29 +3,44 @@
PORTNAME= umit
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= UMIT is the nmap frontend developed with Python and PyGTK
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Nmap frontend developed with Python and PyGTK
-RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+LICENSE= GPLv2
-INSTALLS_ICONS= yes
-USES= tar:bzip2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
+ ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap
+
+NO_ARCH= yes
+
+USES= python tar:bzip2
USE_GNOME= pygtk2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYTHON= distutils
+INSTALLS_ICONS= yes
-NO_STAGE= yes
+PORTDOCS= *
+
+DESKTOP_ENTRIES="Umit" "GUI frontend for Nmap security/port scanner" "umit" \
+ "umit" "System;GTK;" ""
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
post-patch:
- ${REINPLACE_CMD} \
- -e 's/self.build_html_doc()//' \
- -e 's,distutils\.command\.install ,setuptools\.command\.install ,' \
- ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e \
+ 's|distutils\(.command.install\) |setuptools\1 | ; \
+ /self.create_uninstaller()/d ; \
+ /self.pkgmaintainer/s|0|1|' ${WRKSRC}/setup.py
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps
+ @${LN} -sf ${DATADIR}/pixmaps/umit_48x48.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps/umit.png
.include <bsd.port.mk>