aboutsummaryrefslogtreecommitdiffstats
path: root/security/unhide
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-07 03:05:49 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-07 03:05:49 +0800
commitdeb6e0450c6b9f4e310146c8011d6ebe97613a57 (patch)
tree9234fa19162e4040a880595c817f5b0294d1e96d /security/unhide
parent9bb382602ce1db1efd6cbc61e34347e707c006ca (diff)
downloadfreebsd-ports-gnome-deb6e0450c6b9f4e310146c8011d6ebe97613a57.tar.gz
freebsd-ports-gnome-deb6e0450c6b9f4e310146c8011d6ebe97613a57.tar.zst
freebsd-ports-gnome-deb6e0450c6b9f4e310146c8011d6ebe97613a57.zip
- Respect CC and fix build with clang
- Add LICENSE - Remove leading indefinite article from COMMENT - Support STAGEDIR - Remove contiguous blank line from pkg-descr PR: ports/183114 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 17 days)
Diffstat (limited to 'security/unhide')
-rw-r--r--security/unhide/Makefile18
-rw-r--r--security/unhide/files/patch-Makefile21
-rw-r--r--security/unhide/pkg-descr1
3 files changed, 18 insertions, 22 deletions
diff --git a/security/unhide/Makefile b/security/unhide/Makefile
index f4b37ff148a8..52c451353388 100644
--- a/security/unhide/Makefile
+++ b/security/unhide/Makefile
@@ -9,20 +9,20 @@ DISTNAME= ${PORTNAME}_${DISTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ntarmos@ceid.upatras.gr
-COMMENT= A forensic tool to find hidden processes and TCP/UDP ports
+COMMENT= Forensic tool to find hidden processes and TCP/UDP ports
-NO_WRKSUBDIR= true
-PLIST_FILES= sbin/unhide sbin/unhide-tcp
-MAN8= unhide.8 unhide-tcp.8
-MANCOMPRESSED= yes
+LICENSE= GPLv3
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+NO_WRKSUBDIR= true
+PLIST_FILES= man/man8/unhide.8.gz \
+ man/man8/unhide-tcp.8.gz \
+ sbin/unhide \
+ sbin/unhide-tcp
-pre-configure:
+post-patch:
@${REINPLACE_CMD} -e 's/-eLf/-axH/g' -e 's/$$2/$$1/g' ${WRKDIR}/unhide-posix.c
@${REINPLACE_CMD} -e 's/linux\/limits/limits/g' ${WRKDIR}/unhide-output.c
@${REINPLACE_CMD} -e 's/-tan/-p tcp -an/g' -e 's/-uan/-p udp -an/g' \
-e 's/use_ss = 1/use_ss = 0/g' ${WRKDIR}/unhide-tcp.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/unhide/files/patch-Makefile b/security/unhide/files/patch-Makefile
index 744f5b1d7d13..8ca458b624c6 100644
--- a/security/unhide/files/patch-Makefile
+++ b/security/unhide/files/patch-Makefile
@@ -1,8 +1,7 @@
--- /dev/null 2013-01-06 20:26:43.000000000 +0200
+++ Makefile 2013-01-06 20:26:46.000000000 +0200
-@@ -0,0 +1,23 @@
-+DESTDIR := ${PREFIX}
-+MANDIR := ${DESTDIR}/man
+@@ -0,0 +1,20 @@
++MANDIR := ${PREFIX}/man
+INSTALL_PROGRAM := /usr/bin/install -s -m 0700
+INSTALL_MAN := /usr/bin/install -m 0444
+GZIP_CMD := /usr/bin/gzip -9
@@ -11,16 +10,14 @@
+all: unhide unhide-tcp
+
+unhide: unhide-posix.c
-+ gcc -Wall -O2 --static unhide-posix.c -o unhide
++ ${CC} -Wall -O2 --static unhide-posix.c -o unhide
+
+unhide-tcp: unhide-tcp.c unhide-tcp-fast.c unhide-output.c
-+ gcc -Wall -O2 --static unhide-tcp.c unhide-tcp-fast.c unhide-output.c -o unhide-tcp
++ ${CC} -Wall -O2 --static unhide-tcp.c unhide-tcp-fast.c unhide-output.c -o unhide-tcp
+
+install: all
-+ ${MKDIR_CMD} ${DESTDIR}/sbin ${MANDIR}/man8
-+ ${INSTALL_PROGRAM} unhide ${DESTDIR}/sbin/unhide
-+ ${INSTALL_PROGRAM} unhide-tcp ${DESTDIR}/sbin/unhide-tcp
-+ ${INSTALL_MAN} man/unhide.8 ${MANDIR}/man8 && \
-+ ${GZIP_CMD} ${MANDIR}/man8/unhide.8
-+ ${INSTALL_MAN} man/unhide-tcp.8 ${MANDIR}/man8 && \
-+ ${GZIP_CMD} ${MANDIR}/man8/unhide-tcp.8
++ ${MKDIR_CMD} ${DESTDIR}${PREFIX}/sbin ${DESTDIR}${MANDIR}/man8
++ ${INSTALL_PROGRAM} unhide ${DESTDIR}${PREFIX}/sbin/unhide
++ ${INSTALL_PROGRAM} unhide-tcp ${DESTDIR}${PREFIX}/sbin/unhide-tcp
++ ${INSTALL_MAN} man/unhide.8 ${DESTDIR}${MANDIR}/man8
++ ${INSTALL_MAN} man/unhide-tcp.8 ${DESTDIR}${MANDIR}/man8
diff --git a/security/unhide/pkg-descr b/security/unhide/pkg-descr
index 92ce16fa4178..d233337e7a06 100644
--- a/security/unhide/pkg-descr
+++ b/security/unhide/pkg-descr
@@ -11,5 +11,4 @@ unhide detects hidden processes through:
unhide-tcp identifies TCP/UDP ports that are listening but not listed in
/bin/netstat by doing brute forcing of all TCP/UDP ports availables.
-
WWW: http://www.unhide-forensics.info/