aboutsummaryrefslogtreecommitdiffstats
path: root/security/vxquery
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2004-08-18 00:52:19 +0800
committermi <mi@FreeBSD.org>2004-08-18 00:52:19 +0800
commite178c6c76eff58a38c6f7f1f971cb309994ed7d8 (patch)
tree785c45a6ea54811dc3ad1539a43f9cf9a9cc3248 /security/vxquery
parent074b94d5d3e69cbb2ef5b1d84774a3b226a90e11 (diff)
downloadfreebsd-ports-gnome-e178c6c76eff58a38c6f7f1f971cb309994ed7d8.tar.gz
freebsd-ports-gnome-e178c6c76eff58a38c6f7f1f971cb309994ed7d8.tar.zst
freebsd-ports-gnome-e178c6c76eff58a38c6f7f1f971cb309994ed7d8.zip
Don't require a particular version of libexpat. Use sh(1)'s `echo *'
instead of spawning off ls(1) in pkg_check.sh. Approved by: maintainer
Diffstat (limited to 'security/vxquery')
-rw-r--r--security/vxquery/Makefile2
-rw-r--r--security/vxquery/files/pkg_check.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/security/vxquery/Makefile b/security/vxquery/Makefile
index c37e1bfd3ada..a2d77148d7d8 100644
--- a/security/vxquery/Makefile
+++ b/security/vxquery/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= YES
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 501111
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
-LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
.endif
do-install:
diff --git a/security/vxquery/files/pkg_check.sh b/security/vxquery/files/pkg_check.sh
index bd79868393dd..ae31df2fc221 100644
--- a/security/vxquery/files/pkg_check.sh
+++ b/security/vxquery/files/pkg_check.sh
@@ -1,5 +1,4 @@
#! /bin/sh
-LS="/bin/ls"
VXQUERY="vxquery"
PORTSDIR="${PORTSDIR:-/usr/ports}"
PKGDIR="${PKGDIR:-/var/db/pkg}"
@@ -7,4 +6,5 @@ FORMAT="${FORMAT:-text}"
VULN_XML="${VULN_XML:-${PORTSDIR}/security/vuxml/vuln.xml}"
set -e
-(cd "$PKGDIR" && "${LS}") | "${VXQUERY}" -f - -t "${FORMAT}" "${VULN_XML}"
+cd "$PKGDIR"
+echo * | "${VXQUERY}" -f - -t "${FORMAT}" "${VULN_XML}"