aboutsummaryrefslogtreecommitdiffstats
path: root/security/xinetd
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2013-10-03 20:54:10 +0800
committersem <sem@FreeBSD.org>2013-10-03 20:54:10 +0800
commitb93e513764e7a0996bbdb22004fde0eee9483781 (patch)
treeddd9673ab38d14277507e9ce5de66719a2f4f925 /security/xinetd
parent644da977693c575d5cc1ec8195c39cd668c372f2 (diff)
downloadfreebsd-ports-gnome-b93e513764e7a0996bbdb22004fde0eee9483781.tar.gz
freebsd-ports-gnome-b93e513764e7a0996bbdb22004fde0eee9483781.tar.zst
freebsd-ports-gnome-b93e513764e7a0996bbdb22004fde0eee9483781.zip
- Fix CVE-2013-4342: xinetd ignores user and group directives for TCPMUX services
- Rename old-style named file Submitted by: Thomas Swan <thomas.swan@gmail.com>
Diffstat (limited to 'security/xinetd')
-rw-r--r--security/xinetd/Makefile1
-rw-r--r--security/xinetd/files/patch-Makefile.in (renamed from security/xinetd/files/patch-ab)0
-rw-r--r--security/xinetd/files/patch-xinetd::builtins.c11
3 files changed, 12 insertions, 0 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 85e5a1bd4162..86933e00bd88 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xinetd
PORTVERSION= 2.3.15
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://www.xinetd.org/
diff --git a/security/xinetd/files/patch-ab b/security/xinetd/files/patch-Makefile.in
index 5ed041b80d44..5ed041b80d44 100644
--- a/security/xinetd/files/patch-ab
+++ b/security/xinetd/files/patch-Makefile.in
diff --git a/security/xinetd/files/patch-xinetd::builtins.c b/security/xinetd/files/patch-xinetd::builtins.c
new file mode 100644
index 000000000000..49e31e8fce2c
--- /dev/null
+++ b/security/xinetd/files/patch-xinetd::builtins.c
@@ -0,0 +1,11 @@
+--- xinetd/builtins.c.orig 2013-10-03 16:04:32.562080623 +0400
++++ xinetd/builtins.c 2013-10-03 16:04:57.297350342 +0400
+@@ -617,7 +617,7 @@
+ if( SC_IS_INTERNAL( scp ) ) {
+ SC_INTERNAL(scp, nserp);
+ } else {
+- exec_server(nserp);
++ child_process(nserp);
+ }
+ }
+