aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-13 10:37:09 +0800
committerpgj <pgj@FreeBSD.org>2012-02-13 10:37:09 +0800
commit048c0f3f9208d88b0ff5799ca036c5a69679766b (patch)
tree38b1756fef56a318a72c67a37a61602bddda5453 /security
parentc4b494f57b39973edbf1ffbeb3572c56982fc63c (diff)
downloadfreebsd-ports-gnome-048c0f3f9208d88b0ff5799ca036c5a69679766b.tar.gz
freebsd-ports-gnome-048c0f3f9208d88b0ff5799ca036c5a69679766b.tar.zst
freebsd-ports-gnome-048c0f3f9208d88b0ff5799ca036c5a69679766b.zip
Achieves security through AES-CTR encryption and Skein-MAC-512-256
authentication. Uses Base64 encoding to avoid any issues with characters. WWW: http://github.com/snoyberg/clientsession/tree/master Obtained from: FreeBSD Haskell
Diffstat (limited to 'security')
-rw-r--r--security/hs-clientsession/Makefile22
-rw-r--r--security/hs-clientsession/distinfo2
-rw-r--r--security/hs-clientsession/pkg-descr5
3 files changed, 29 insertions, 0 deletions
diff --git a/security/hs-clientsession/Makefile b/security/hs-clientsession/Makefile
new file mode 100644
index 000000000000..e3c9ed130bd9
--- /dev/null
+++ b/security/hs-clientsession/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-clientsession
+# Date created: November 19, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= clientsession
+PORTVERSION= 0.7.4
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Securely store session data in a client-side cookie
+
+LICENSE= BSD
+
+USE_CABAL= base64-bytestring>=0.1.0.3 cereal>=0.3 cprng-aes>=0.2 \
+ crypto-api>=0.6.4 cryptocipher>=0.2.5 entropy>=0.2.1 \
+ skein>=0.1 tagged>=0.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-clientsession/distinfo b/security/hs-clientsession/distinfo
new file mode 100644
index 000000000000..1d72e89fcf6f
--- /dev/null
+++ b/security/hs-clientsession/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/clientsession-0.7.4.tar.gz) = 5a6f7a025dd11087f444795f159dd3e7ea610a0eec869d96d8a451fff3781514
+SIZE (cabal/clientsession-0.7.4.tar.gz) = 7004
diff --git a/security/hs-clientsession/pkg-descr b/security/hs-clientsession/pkg-descr
new file mode 100644
index 000000000000..29c98b7049ab
--- /dev/null
+++ b/security/hs-clientsession/pkg-descr
@@ -0,0 +1,5 @@
+Achieves security through AES-CTR encryption and Skein-MAC-512-256
+authentication. Uses Base64 encoding to avoid any issues with
+characters.
+
+WWW: http://github.com/snoyberg/clientsession/tree/master