aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
committerMark Linimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
commit06e66777937202f04d646d24d24f524b13d79478 (patch)
tree85a44213b1929b12051c17091ea4ad53f819456b /security
parent63d4112e2e682002806fc4c52da2481ae7f045e7 (diff)
downloadfreebsd-ports-gnome-06e66777937202f04d646d24d24f524b13d79478.tar.gz
freebsd-ports-gnome-06e66777937202f04d646d24d24f524b13d79478.tar.zst
freebsd-ports-gnome-06e66777937202f04d646d24d24f524b13d79478.zip
Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
Diffstat (limited to 'security')
-rw-r--r--security/burpsuite/Makefile2
-rw-r--r--security/dirbuster/Makefile2
-rw-r--r--security/iaikpkcs11wrapper/Makefile2
-rw-r--r--security/webscarab/Makefile2
-rw-r--r--security/xml-security/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/security/burpsuite/Makefile b/security/burpsuite/Makefile
index 2222d4f6d591..58608c1907bc 100644
--- a/security/burpsuite/Makefile
+++ b/security/burpsuite/Makefile
@@ -16,7 +16,7 @@ COMMENT= Burp Suite is an integrated platform for testing web applications
USE_ZIP= YES
USE_JAVA= YES
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/security/dirbuster/Makefile b/security/dirbuster/Makefile
index 5f0e4c25d420..9f36fbb2caba 100644
--- a/security/dirbuster/Makefile
+++ b/security/dirbuster/Makefile
@@ -16,7 +16,7 @@ COMMENT= DirBuster allows file and directory brute forcing on web servers
USE_ZIP= YES
USE_JAVA= YES
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
diff --git a/security/iaikpkcs11wrapper/Makefile b/security/iaikpkcs11wrapper/Makefile
index e7bf3858ea16..f04d928b9441 100644
--- a/security/iaikpkcs11wrapper/Makefile
+++ b/security/iaikpkcs11wrapper/Makefile
@@ -18,7 +18,7 @@ COMMENT= A PKCS\#11 Java wrapper
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.2+
+JAVA_VERSION= 1.5+
JAVA_OS= native
USE_GMAKE= yes
ALL_TARGET= release
diff --git a/security/webscarab/Makefile b/security/webscarab/Makefile
index a66fc41b7bdb..222c9b0ec2d5 100644
--- a/security/webscarab/Makefile
+++ b/security/webscarab/Makefile
@@ -17,7 +17,7 @@ COMMENT= Framework for analysing HTTP and HTTPS web application traffic
USE_ZIP= YES
USE_JAVA= YES
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${DISTNAME}-1304
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
diff --git a/security/xml-security/Makefile b/security/xml-security/Makefile
index 16c7e70c35f1..d251600453b1 100644
--- a/security/xml-security/Makefile
+++ b/security/xml-security/Makefile
@@ -25,7 +25,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./_/g}
USE_ANT= yes
MAKE_ENV= ANT_INCLUDE_SHARED_JARS=YES