aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-10-15 21:37:48 +0800
committerale <ale@FreeBSD.org>2013-10-15 21:37:48 +0800
commit0773056b67ffb6e0a7859ebebae46641b5010750 (patch)
tree246c5b813d5b93f221bc25f157ce7d76de62f671 /security
parent20bd19eb68c33c656f250be5056b74a59cdb5cb7 (diff)
downloadfreebsd-ports-gnome-0773056b67ffb6e0a7859ebebae46641b5010750.tar.gz
freebsd-ports-gnome-0773056b67ffb6e0a7859ebebae46641b5010750.tar.zst
freebsd-ports-gnome-0773056b67ffb6e0a7859ebebae46641b5010750.zip
Update to 1.5.5 release (OPTIONify & STAGEify).
Diffstat (limited to 'security')
-rw-r--r--security/xml-security/Makefile34
-rw-r--r--security/xml-security/distinfo4
2 files changed, 24 insertions, 14 deletions
diff --git a/security/xml-security/Makefile b/security/xml-security/Makefile
index 2ba66b088381..65de16028ddd 100644
--- a/security/xml-security/Makefile
+++ b/security/xml-security/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xml-security
-PORTVERSION= 1.5.3
+PORTVERSION= 1.5.5
CATEGORIES= security java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= santuario/java-library/${PORTVERSION:S/./_/g}
@@ -17,6 +17,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:${PORTSDIR}/java/jakarta-commons-
LICENSE= AL2
+OPTIONS_DEFINE= DOCS EXAMPLES
USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -24,30 +25,39 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./_/g}
USE_ANT= yes
MAKE_ENV= ANT_INCLUDE_SHARED_JARS=YES
ALL_TARGET= jar
-.if !defined(NOPORTDOCS)
-ALL_TARGET+= javadoc
-.endif
PORTDOCS= *
PORTEXAMPLES= *
PLIST_FILES= %%JAVAJARDIR%%/xmlsec.jar
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+ALL_TARGET+= javadoc
+.endif
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${ANT} ${ALL_TARGET})
+
do-install:
@${ECHO} -n ">> Installing JAR as ${JAVAJARDIR}/xmlsec.jar..."
- @${INSTALL_DATA} ${WRKSRC}/build/xmlsec-${PORTVERSION}.jar ${JAVAJARDIR}/xmlsec.jar
+ @${INSTALL_DATA} ${WRKSRC}/build/xmlsec-${PORTVERSION}.jar \
+ ${STAGEDIR}/${JAVAJARDIR}/xmlsec.jar
@${ECHO} " [ DONE ]"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/build/docs/html && ${COPYTREE_SHARE} javadoc ${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ @(cd ${WRKSRC}/build/docs/html && ${COPYTREE_SHARE} javadoc \
+ ${STAGEDIR}/${DOCSDIR})
@${ECHO} " [ DONE ]"
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${ECHO} -n ">> Installing examples in ${EXAMPLESDIR}..."
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/samples && ${COPYTREE_SHARE} "javax org" ${EXAMPLESDIR})
+ @${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}
+ @(cd ${WRKSRC}/samples && ${COPYTREE_SHARE} "javax org" \
+ ${STAGEDIR}/${EXAMPLESDIR})
@${ECHO} " [ DONE ]"
.endif
diff --git a/security/xml-security/distinfo b/security/xml-security/distinfo
index 0766b04a0023..ad45101fac37 100644
--- a/security/xml-security/distinfo
+++ b/security/xml-security/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xml-security-src-1_5_3.zip) = 0eb4cfa83bfb6ff3beee87f193d0bc6c45902d2bd3c6c7fb315a3e014dc15fdf
-SIZE (xml-security-src-1_5_3.zip) = 2436355
+SHA256 (xml-security-src-1_5_5.zip) = 68d0e567134913a1ba9571b587980306522f34d66ff495d065f734c08cc793c0
+SIZE (xml-security-src-1_5_5.zip) = 2437645