aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-10-07 16:02:55 +0800
committerale <ale@FreeBSD.org>2006-10-07 16:02:55 +0800
commit0b38bf484f42664af59c7cd857745a32b81af9c1 (patch)
tree48d1f380158d08e6e2fee37b4e40c7ca758d5582 /security
parenta90802143a4bf1cf13f6123c919857801c9505eb (diff)
downloadfreebsd-ports-gnome-0b38bf484f42664af59c7cd857745a32b81af9c1.tar.gz
freebsd-ports-gnome-0b38bf484f42664af59c7cd857745a32b81af9c1.tar.zst
freebsd-ports-gnome-0b38bf484f42664af59c7cd857745a32b81af9c1.zip
Try to fix on 4.X.
Diffstat (limited to 'security')
-rw-r--r--security/cryptlib/Makefile1
-rw-r--r--security/openct/files/patch-src_ifd_ifd-wbeiuu.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index dd35a77502aa..727411058ba2 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -26,6 +26,7 @@ NO_WRKSUBDIR= yes
USE_GMAKE= yes
MAKEFILE= makefile
ALL_TARGET= default FreeBSD shared
+USE_GCC= 3.2+
USE_LDCONFIG= yes
PORTDOCS= README
diff --git a/security/openct/files/patch-src_ifd_ifd-wbeiuu.c b/security/openct/files/patch-src_ifd_ifd-wbeiuu.c
new file mode 100644
index 000000000000..cb9ec044f58f
--- /dev/null
+++ b/security/openct/files/patch-src_ifd_ifd-wbeiuu.c
@@ -0,0 +1,18 @@
+--- src/ifd/ifd-wbeiuu.c.orig Sat Oct 7 09:55:18 2006
++++ src/ifd/ifd-wbeiuu.c Sat Oct 7 09:57:25 2006
+@@ -454,6 +454,7 @@
+ {
+ int status;
+ unsigned char buf[256];
++ unsigned char len;
+ ifd_device_t *dev;
+
+ ifd_debug(1, "%s:%d wbeiuu_card_reset()", __FILE__, __LINE__);
+@@ -504,7 +505,6 @@
+ return -1;
+ }
+ //unsigned char len[1] = { 0x00 };
+- unsigned char len;
+ ifd_debug(1, "%s:%d How many bytes waiting at the FIFO?", __FILE__,
+ __LINE__, status);
+ status = ifd_sysdep_usb_bulk(dev, 0x82, &len, 1, USB_TIMEOUT);