aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2005-05-18 00:44:39 +0800
committerume <ume@FreeBSD.org>2005-05-18 00:44:39 +0800
commit0e4981ede7df88da830fa2dfe21af2e5c56dedfd (patch)
tree3781d15ea5fbf9c6bd6c29111fed42ad3acaffd4 /security
parent1349526b804a3809311595dabf60c0aee2966a9e (diff)
downloadfreebsd-ports-gnome-0e4981ede7df88da830fa2dfe21af2e5c56dedfd.tar.gz
freebsd-ports-gnome-0e4981ede7df88da830fa2dfe21af2e5c56dedfd.tar.zst
freebsd-ports-gnome-0e4981ede7df88da830fa2dfe21af2e5c56dedfd.zip
New port -- SASL LDAPDB auxprop plugin
Though this is actually part of Cyrus SASL2, we cannot simply enable it in security/cyrus-sasl2 to avoid dependency loop with net/openldap.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/cyrus-sasl2-ldapdb/Makefile78
-rw-r--r--security/cyrus-sasl2-ldapdb/pkg-descr3
3 files changed, 82 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 80f0d78a30a8..78273885e8bd 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -64,6 +64,7 @@
SUBDIR += cvm
SUBDIR += cyrus-sasl
SUBDIR += cyrus-sasl2
+ SUBDIR += cyrus-sasl2-ldapdb
SUBDIR += cyrus-sasl2-saslauthd
SUBDIR += dazuko
SUBDIR += dcetest
diff --git a/security/cyrus-sasl2-ldapdb/Makefile b/security/cyrus-sasl2-ldapdb/Makefile
new file mode 100644
index 000000000000..b4500df405a6
--- /dev/null
+++ b/security/cyrus-sasl2-ldapdb/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: cyrus-sasl2-ldapdb
+# Date created: May 18 2005
+# Whom: ume@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ldapdb
+PORTVERSION= 2.1.21
+#PORTREVISION= 0
+CATEGORIES= security ipv6
+MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/%SUBDIR%/ \
+ ftp://ftp.westbend.net/pub/cyrus-mail/%SUBDIR%/ \
+ ftp://ftp.hanse.de/sites/transit/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/%SUBDIR%/
+MASTER_SITE_SUBDIR= . OLD-VERSIONS/sasl
+PKGNAMEPREFIX= cyrus-sasl-
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= SASL LDAPDB auxprop plugin
+
+LIB_DEPENDS= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+
+CYRUS_SASL2_DIR=${MASTERDIR}/../cyrus-sasl2
+MD5_FILE= ${CYRUS_SASL2_DIR}/distinfo
+PATCHDIR= ${CYRUS_SASL2_DIR}/files
+INSTALL_WRKSRC= ${WRKDIR}/${DISTNAME}/plugins
+
+INSTALLS_SHLIB= yes
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+
+.if defined(WITH_OPENLDAP_VER)
+WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
+.endif
+.if defined(WANT_OPENLDAP_VER) && ${WANT_OPENLDAP_VER} == 12
+BROKEN= "this port requires OpenLDAP >= 2.0"
+.endif
+USE_OPENLDAP= yes
+
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
+ --with-plugindir=${PREFIX}/lib/sasl2 \
+ --with-dbpath=${PREFIX}/etc/sasldb2 \
+ --includedir=${PREFIX}/include \
+ --mandir=${MANPREFIX}/man \
+ --enable-static \
+ --with-rc4=openssl
+
+CONFIGURE_ARGS+=--with-dblib=none \
+ --disable-anon \
+ --disable-cram \
+ --disable-digest \
+ --disable-gssapi \
+ --disable-krb4 \
+ --disable-ntlm \
+ --disable-otp \
+ --disable-plain
+
+CONFIGURE_ARGS+=--enable-ldapdb --with-ldap=${LOCALBASE}
+
+PLIST_FILES= lib/sasl2/libldapdb.a \
+ lib/sasl2/libldapdb.so \
+ lib/sasl2/libldapdb.so.2
+
+.include <bsd.port.pre.mk>
+
+.if ${OPENSSLBASE} == /usr
+CONFIGURE_ARGS+=--with-openssl=yes
+.else
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
+.endif
+
+do-build:
+ cd ${WRKSRC}/include && ${MAKE}
+ cd ${WRKSRC}/plugins && ${MAKE}
+
+.include <bsd.port.post.mk>
diff --git a/security/cyrus-sasl2-ldapdb/pkg-descr b/security/cyrus-sasl2-ldapdb/pkg-descr
new file mode 100644
index 000000000000..446dd80c70c0
--- /dev/null
+++ b/security/cyrus-sasl2-ldapdb/pkg-descr
@@ -0,0 +1,3 @@
+SASL LDAPDB auxprop plugin
+
+WWW: http://asg.web.cmu.edu/sasl/