aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2015-02-05 04:44:21 +0800
committerzi <zi@FreeBSD.org>2015-02-05 04:44:21 +0800
commit0ee3a761b1aebee1016d5dcc9710ed18f44ed97d (patch)
treede8ffc2ec72ab6575c1b02f4c12663f5ecc29169 /security
parent7d04cac272ac36b2f78f32512312e56da3ece283 (diff)
downloadfreebsd-ports-gnome-0ee3a761b1aebee1016d5dcc9710ed18f44ed97d.tar.gz
freebsd-ports-gnome-0ee3a761b1aebee1016d5dcc9710ed18f44ed97d.tar.zst
freebsd-ports-gnome-0ee3a761b1aebee1016d5dcc9710ed18f44ed97d.zip
New port: security/kstart:
k5start is a modified version of kinit that can use keytabs to authenticate, can run as a daemon and wake up periodically to refresh a ticket, and can run single commands with their own authentication credentials and refresh those credentials until the command exits. It is commonly used to maintain Kerberos tickets for services that need to authenticate to minimize the amount of Kerberos-related logic that must be in the service itself. WWW: http://www.eyrie.org/~eagle/software/kstart/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/kstart/Makefile24
-rw-r--r--security/kstart/distinfo2
-rw-r--r--security/kstart/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4ecdd981179a..a0a9e250e9af 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -257,6 +257,7 @@
SUBDIR += krb5-112
SUBDIR += krb5-appl
SUBDIR += kripp
+ SUBDIR += kstart
SUBDIR += kwalletmanager
SUBDIR += l0pht-watch
SUBDIR += l0phtcrack
diff --git a/security/kstart/Makefile b/security/kstart/Makefile
new file mode 100644
index 000000000000..d0af6e19d9f9
--- /dev/null
+++ b/security/kstart/Makefile
@@ -0,0 +1,24 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= kstart
+DISTVERSION= 4.1
+CATEGORIES= security
+MASTER_SITES= http://archives.eyrie.org/software/kerberos/
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Automated Kerberos ticket cache and keytab management utilities
+
+HAS_CONFIGURE= yes
+PLIST_FILES= bin/k5start bin/krenew \
+ man/man1/k5start.1.gz man/man1/krenew.1.gz
+
+do-install:
+ @${GZIP_CMD} ${WRKSRC}/k5start.1
+ @${GZIP_CMD} ${WRKSRC}/krenew.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/k5start ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/krenew ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/k5start.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/krenew.1.gz ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/kstart/distinfo b/security/kstart/distinfo
new file mode 100644
index 000000000000..1a12ea460127
--- /dev/null
+++ b/security/kstart/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kstart-4.1.tar.gz) = ad1a71be149d56473319bf3b9bca83a60caa3af463d52c134e8f187103700224
+SIZE (kstart-4.1.tar.gz) = 269215
diff --git a/security/kstart/pkg-descr b/security/kstart/pkg-descr
new file mode 100644
index 000000000000..e79ef6d566c9
--- /dev/null
+++ b/security/kstart/pkg-descr
@@ -0,0 +1,10 @@
+k5start is a modified version of kinit that can use keytabs to authenticate,
+can run as a daemon and wake up periodically to refresh a ticket, and can run
+single commands with their own authentication credentials and refresh those
+credentials until the command exits.
+
+It is commonly used to maintain Kerberos tickets for services that need to
+authenticate to minimize the amount of Kerberos-related logic that must be
+in the service itself.
+
+WWW: http://www.eyrie.org/~eagle/software/kstart/