aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-26 17:01:42 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-26 17:01:42 +0800
commit0fc67ef5075852e38108a6f219f02603a750ea10 (patch)
tree1f453720991cb353fd71520308b81d35a7836226 /security
parent3f99089402557e4556902d6cd3732505372e006b (diff)
downloadfreebsd-ports-gnome-0fc67ef5075852e38108a6f219f02603a750ea10.tar.gz
freebsd-ports-gnome-0fc67ef5075852e38108a6f219f02603a750ea10.tar.zst
freebsd-ports-gnome-0fc67ef5075852e38108a6f219f02603a750ea10.zip
- Add LICENSE
- Simplify installation - Switch to options helpers
Diffstat (limited to 'security')
-rw-r--r--security/secure_delete/Makefile13
-rw-r--r--security/secure_delete/files/patch-Makefile4
2 files changed, 8 insertions, 9 deletions
diff --git a/security/secure_delete/Makefile b/security/secure_delete/Makefile
index fa0c787f14db..c23da4e99f02 100644
--- a/security/secure_delete/Makefile
+++ b/security/secure_delete/Makefile
@@ -11,6 +11,8 @@ MASTER_SITES= PACKETSTORM/groups/thc \
MAINTAINER= ports@FreeBSD.org
COMMENT= Secure data deletion toolkit
+LICENSE= GPLv2 # mentioned in manpages
+
CONFLICTS= srm-[0-9]*
MAKE_JOBS_UNSAFE= yes
@@ -22,9 +24,6 @@ PLIST_FILES= bin/sdel bin/sfill bin/smem bin/srm bin/sswap \
bin/the_cleaner.sh man/man1/sfill.1.gz man/man1/smem.1.gz \
man/man1/srm.1.gz man/man1/sswap.1.gz
-BIN_PROGRAMS= srm sfill sswap smem
-BIN_SCRIPTS= the_cleaner.sh
-
OPTIONS_DEFINE= DOCS
post-extract:
@@ -37,14 +36,14 @@ post-patch:
/strip/s|^|#|' ${WRKSRC}/Makefile
do-install:
-.for i in ${BIN_PROGRAMS}
+.for i in srm sfill sswap smem
${INSTALL_PROGRAM} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${i}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
-.for i in ${BIN_SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
-.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/the_cleaner.sh ${STAGEDIR}${PREFIX}/bin
${LN} -sf srm ${STAGEDIR}${PREFIX}/bin/sdel
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
diff --git a/security/secure_delete/files/patch-Makefile b/security/secure_delete/files/patch-Makefile
index 719d7da471cb..7f13f2869dee 100644
--- a/security/secure_delete/files/patch-Makefile
+++ b/security/secure_delete/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig
+--- Makefile.orig 2003-10-29 21:07:06 UTC
+++ Makefile
@@ -1,13 +1,12 @@
-CC=gcc
@@ -19,7 +19,7 @@
@echo
@echo "A Puritan is someone who is deathly afraid that someone, somewhere, is"
@echo "having fun."
-@@ -47,7 +46,7 @@
+@@ -47,7 +46,7 @@ install: all
chmod 644 ${MAN_DIR}/man1/srm.1 ${MAN_DIR}/man1/sfill.1 ${MAN_DIR}/man1/sswap.1 ${MAN_DIR}/man1/smem.1
mkdir -p -m 755 ${DOC_DIR} 2> /dev/null
cp -f CHANGES FILES README secure_delete.doc usenix6-gutmann.doc ${DOC_DIR}