aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-09-26 18:26:06 +0800
committerclsung <clsung@FreeBSD.org>2006-09-26 18:26:06 +0800
commit102423665ff626827a3a3501f8e424a266ba7d0a (patch)
tree324eb9edabd4ec267fad9b72c5fb34e3ece5b33f /security
parentaecb7d5a4343a56e88e3a3d6186557dddf701e70 (diff)
downloadfreebsd-ports-gnome-102423665ff626827a3a3501f8e424a266ba7d0a.tar.gz
freebsd-ports-gnome-102423665ff626827a3a3501f8e424a266ba7d0a.tar.zst
freebsd-ports-gnome-102423665ff626827a3a3501f8e424a266ba7d0a.zip
Add blocksshd 0.8, protects computers from SSH brute force attacks.
PR: ports/102367 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/blocksshd/Makefile34
-rw-r--r--security/blocksshd/distinfo3
-rw-r--r--security/blocksshd/files/patch-blocksshd.conf23
-rw-r--r--security/blocksshd/pkg-descr4
-rw-r--r--security/blocksshd/pkg-plist3
6 files changed, 68 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 83e2769f3129..b7d8c3375deb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -35,6 +35,7 @@
SUBDIR += bioapi
SUBDIR += bioapitool
SUBDIR += bjorb
+ SUBDIR += blocksshd
SUBDIR += borzoi
SUBDIR += botan
SUBDIR += bro
diff --git a/security/blocksshd/Makefile b/security/blocksshd/Makefile
new file mode 100644
index 000000000000..5e47b391ae2a
--- /dev/null
+++ b/security/blocksshd/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: blocksshd
+# Date created: 2006-07-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blocksshd
+PORTVERSION= 0.8
+CATEGORIES= security sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= blocksshd
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Protects computers from SSH brute force attacks
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS/Resolver.pm:${PORTSDIR}/dns/p5-Net-DNS \
+ ${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail \
+ ${SITE_PERL}/Proc/Daemon.pm:${PORTSDIR}/devel/p5-Proc-Daemon \
+ ${SITE_PERL}/Proc/PID/File.pm:${PORTSDIR}/devel/p5-Proc-PID-File
+
+MAKE_ARGS= PREFIX="${TARGETDIR}"
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+MAN1= blocksshd.1
+
+post-patch:
+ @${CHMOD} 755 ${WRKSRC}/init
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/blocksshd.conf ${TARGETDIR}/etc
+
+.include <bsd.port.mk>
diff --git a/security/blocksshd/distinfo b/security/blocksshd/distinfo
new file mode 100644
index 000000000000..9acb12c761b8
--- /dev/null
+++ b/security/blocksshd/distinfo
@@ -0,0 +1,3 @@
+MD5 (blocksshd-0.8.tar.gz) = 0e92913e9f1014a7484a8c230b21637e
+SHA256 (blocksshd-0.8.tar.gz) = 17763703be029249081fbfe6f0422a84900a4c6dc0d8d3894311aeda9b31585f
+SIZE (blocksshd-0.8.tar.gz) = 9835
diff --git a/security/blocksshd/files/patch-blocksshd.conf b/security/blocksshd/files/patch-blocksshd.conf
new file mode 100644
index 000000000000..fd05fd8ad2dd
--- /dev/null
+++ b/security/blocksshd/files/patch-blocksshd.conf
@@ -0,0 +1,23 @@
+--- blocksshd.conf.orig Wed Jul 19 18:57:06 2006
++++ blocksshd.conf Tue Sep 26 16:57:13 2006
+@@ -1,9 +1,9 @@
+ # vim: syntax=perl
+
+ $cfg = {
+- os => 'linux', # Target OS - either linux or bsd
++ os => 'bsd', # Target OS - either linux or bsd
+ chain => 'blocksshd', # Name of iptables or pf chain
+- logfile => '/var/log/secure', # Log file to monitor
++ logfile => '/var/log/auth.log', # Log file to monitor
+ logcheck => '10', # How often to check the log file
+ max_attempts => '4', # Max number of failures
+ timeout => '360', # Reset IP count if no activity after time out in seconds
+@@ -14,7 +14,7 @@
+ pid_file => '/var/run/blocksshd.pid', # Location of PID file
+ send_email => '1', # Enable the sending of email notifications
+ email => 'root', # Email address to send notifications
+- mail => '/bin/mail', # Location of mail binary
++ mail => '/usr/bin/mail', # Location of mail binary
+ iptables => '/sbin/iptables', # Location of iptables binary - only for Linux
+ pfctl => '/sbin/pfctl', # Location of pfctl binary - only for BSD
+ whitelist => [qw{
diff --git a/security/blocksshd/pkg-descr b/security/blocksshd/pkg-descr
new file mode 100644
index 000000000000..0e4f78b55434
--- /dev/null
+++ b/security/blocksshd/pkg-descr
@@ -0,0 +1,4 @@
+BlockSSHD protects computers from SSH brute force attacks by
+dynamically blocking IP addresses by adding iptables rules.
+
+WWW: http://sourceforge.net/projects/blocksshd/
diff --git a/security/blocksshd/pkg-plist b/security/blocksshd/pkg-plist
new file mode 100644
index 000000000000..1977023c3021
--- /dev/null
+++ b/security/blocksshd/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+bin/blocksshd
+etc/blocksshd.conf