aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>1999-11-15 14:18:46 +0800
committergreen <green@FreeBSD.org>1999-11-15 14:18:46 +0800
commit105306bdf57a1278f04aa7ff104d6d551577f9d5 (patch)
tree1358c0ad5e3067fac32196a174a8b18e4f56c2cb /security
parent3279240aea538c13f74c109421e5004f2a14de85 (diff)
downloadfreebsd-ports-gnome-105306bdf57a1278f04aa7ff104d6d551577f9d5.tar.gz
freebsd-ports-gnome-105306bdf57a1278f04aa7ff104d6d551577f9d5.tar.zst
freebsd-ports-gnome-105306bdf57a1278f04aa7ff104d6d551577f9d5.zip
Enable TCP wrapper support (conditionalized to turn off if tcpd.h is
nonexistant). Also, add the Makefile hooks for AFS, Kerberos, and S/Key.
Diffstat (limited to 'security')
-rw-r--r--security/openssh/Makefile11
-rw-r--r--security/openssh/files/patch-ab8
2 files changed, 14 insertions, 5 deletions
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 34c6e1065c66..b3cef210d607 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -30,7 +30,16 @@ CRYPTOLIBS+= -lRSAglue -lrsaref
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV= DESTDIR=${PREFIX} MANDIR=/man/man CRYPTOLIBS="${CRYPTOLIBS}"
.if !exists(/usr/include/tcpd.h)
-MAKE_ENV+= TCP_WRAPPERS=NO
+MAKE_ENV+= TCP_WRAPPERS=no
+.endif
+.if defined(AFS) && ${AFS} == YES
+MAKE_ENV+= AFS=yes
+.endif
+.if defined(KERBEROS) && ${KERBEROS} == YES
+MAKE_ENV+= KERBEROS=yes
+.endif
+.if defined(SKEY) && ${SKEY} == YES
+MAKE_ENV+= SKEY=yes
.endif
STAMPFILE= ${DISTDIR}/${PKGNAME}/.stamp
WRKSRC= ${WRKDIR}/ssh
diff --git a/security/openssh/files/patch-ab b/security/openssh/files/patch-ab
index a2a1f00e365b..a65c47f7601c 100644
--- a/security/openssh/files/patch-ab
+++ b/security/openssh/files/patch-ab
@@ -10,10 +10,10 @@
-LDADD+= -L${.CURDIR}/../lib/${__objdir} -lssh
-DPADD+= ${.CURDIR}/../lib/${__objdir}/libssh.a
-.else
-+AFS?= NO
-+KERBEROS?= NO
-+SKEY?= NO
-+TCP_WRAPPERS?= YES
++AFS?= no
++KERBEROS?= no
++SKEY?= no
++TCP_WRAPPERS?= yes
LDADD+= -L${.CURDIR}/../lib -lssh
DPADD+= ${.CURDIR}/../lib/libssh.a
-.endif