aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-12-30 13:38:19 +0800
committerCy Schubert <cy@FreeBSD.org>2020-12-30 13:38:19 +0800
commit126f796a3f7c835eb0501a2e4d6159f523c71793 (patch)
treefc714b82f0a571bc263182cecebf6f5e8d8ffab8 /security
parent4e368d60f607f336fff60411e278bebfa3113458 (diff)
downloadfreebsd-ports-gnome-126f796a3f7c835eb0501a2e4d6159f523c71793.tar.gz
freebsd-ports-gnome-126f796a3f7c835eb0501a2e4d6159f523c71793.tar.zst
freebsd-ports-gnome-126f796a3f7c835eb0501a2e4d6159f523c71793.zip
Add SIM_SIMULATOR and USIM_SIMULATOR options.
SIM_SIMULATOR and USIM_SIMULATOR options enable features that are used for testing EAP-AKA and EAP-SIM authentication. PR: 252276 Submitted by: Terry Burton <tez _ terryburton.co.uk>
Diffstat (limited to 'security')
-rw-r--r--security/wpa_supplicant/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index b0fffc60ded2..0d5a0eedb04d 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -43,7 +43,8 @@ OPTIONS_DEFINE= WPS WPS_ER WPS_NOREG WPS_NFC WPS_UPNP PKCS12 SMARTCARD \
IEEE80211R DEBUG_FILE DEBUG_SYSLOG PRIVSEP \
DELAYED_MIC IEEE80211N IEEE80211AC INTERWORKING \
IEEE8021X_EAPOL EAPOL_TEST \
- HS20 NO_ROAMING P2P TDLS DBUS MATCH DOCS
+ HS20 NO_ROAMING P2P TDLS DBUS MATCH DOCS \
+ SIM_SIMULATOR USIM_SIMULATOR
OPTIONS_DEFAULT= BSD WIRED NDIS \
TLS PEAP TTLS MD5 MSCHAPV2 GTC LEAP OTP PSK \
WPS PKCS12 SMARTCARD IEEE80211R DEBUG_SYSLOG \
@@ -102,6 +103,8 @@ AKA_DESC= Autentication and Key Agreement (UMTS)
AKA_PRIME_DESC= AKA Prime variant (RFC 5448)
EKE_DESC= Encrypted Key Exchange
SIM_DESC= Subscriber Identity Module
+SIM_SIMULATOR_DESC= SIM simulator (Milenage) for EAP-SIM
+USIM_SIMULATOR_DESC= SIM simulator (Milenage) for EAP-AKA
IKEV2_DESC= Internet Key Exchange version 2
PWD_DESC= Shared password (RFC 5931)
PAX_DESC= Password Authenticated Exchange
@@ -183,6 +186,12 @@ post-patch:
.if ${PORT_OPTIONS:MMATCH}
@${ECHO_CMD} CONFIG_MATCH_IFACE=y >> ${CFG}
.endif
+.if ${PORT_OPTIONS:MUSIM_SIMULATOR}
+ @${ECHO_CMD} CONFIG_USIM_SIMULATOR=y >> ${CFG}
+.endif
+.if ${PORT_OPTIONS:MSIM_SIMULATOR}
+ @${ECHO_CMD} CONFIG_SIM_SIMULATOR=y >> ${CFG}
+.endif
@${ECHO_CMD} CONFIG_OS=unix >> ${CFG}
@${ECHO_CMD} CONFIG_CTRL_IFACE=unix >> ${CFG}
@${ECHO_CMD} CONFIG_BACKEND=file >> ${CFG}