aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-09-10 03:32:28 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-09-10 03:32:28 +0800
commit13bc1e4369792873fc63d20a8dd5ab8a2bae9a16 (patch)
tree60055126b07e4d620e9d860973a5cea6d7ed4509 /security
parent91024d3703ae029091bb732fdc64056cc88f4636 (diff)
downloadfreebsd-ports-gnome-13bc1e4369792873fc63d20a8dd5ab8a2bae9a16.tar.gz
freebsd-ports-gnome-13bc1e4369792873fc63d20a8dd5ab8a2bae9a16.tar.zst
freebsd-ports-gnome-13bc1e4369792873fc63d20a8dd5ab8a2bae9a16.zip
Add totp-cli 1.1.1
This is a simple TOTP (Time-based One-time Password) CLI tool. TOTP is the most common mechanism for 2FA (Two-Factor-Authentication). You can manage and organize your accounts with namespaces and protect your data with a password. WWW: https://github.com/yitsushi/totp-cli
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/totp-cli/Makefile31
-rw-r--r--security/totp-cli/distinfo15
-rw-r--r--security/totp-cli/pkg-descr5
4 files changed, 52 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ec20d83849d8..2b12e3fbe2c1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1279,6 +1279,7 @@
SUBDIR += tlswrap
SUBDIR += tor
SUBDIR += tor-devel
+ SUBDIR += totp-cli
SUBDIR += tpm-tools
SUBDIR += trezord
SUBDIR += trinokiller
diff --git a/security/totp-cli/Makefile b/security/totp-cli/Makefile
new file mode 100644
index 000000000000..f2ac70a6feb9
--- /dev/null
+++ b/security/totp-cli/Makefile
@@ -0,0 +1,31 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= totp-cli
+PORTVERSION= 1.1.1
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Authy/Google Authenticator like TOTP CLI tool
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= go:modules
+
+PLIST_FILES= bin/totp-cli
+
+GH_ACCOUNT= yitsushi
+GH_TUPLE= golang:crypto:71b5226:golang_crypto/vendor/golang.org/x/crypto \
+ golang:sys:749cb33:golang_sys/vendor/golang.org/x/sys \
+ kardianos:osext:2bc1f35:kardianos_osext/vendor/github.com/kardianos/osext \
+ mitchellh:go-homedir:v1.1.0:mitchellh_gohomedir/vendor/github.com/mitchellh/go-homedir \
+ yitsushi:github-release-check:v1.0.1:yitsushi_github_release_check/vendor/github.com/yitsushi/github-release-check \
+ yitsushi:go-commander:v1.1.0:yitsushi_go_commander/vendor/github.com/yitsushi/go-commander
+USE_GITHUB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/totp-cli ${STAGEDIR}${PREFIX}/bin/totp-cli
+
+.include <bsd.port.mk>
diff --git a/security/totp-cli/distinfo b/security/totp-cli/distinfo
new file mode 100644
index 000000000000..683e6b1fb914
--- /dev/null
+++ b/security/totp-cli/distinfo
@@ -0,0 +1,15 @@
+TIMESTAMP = 1567893266
+SHA256 (yitsushi-totp-cli-v1.1.1_GH0.tar.gz) = a57b2b98f011cc7bc53c657575baf6225fd4b4d1112c4dcc1cc11d7f366916eb
+SIZE (yitsushi-totp-cli-v1.1.1_GH0.tar.gz) = 22360
+SHA256 (golang-crypto-71b5226_GH0.tar.gz) = 7ab66566a1792bf53b26474bf023d0607e59158af6a1321d94c56de433cb083b
+SIZE (golang-crypto-71b5226_GH0.tar.gz) = 1693011
+SHA256 (golang-sys-749cb33_GH0.tar.gz) = 14cd0776aff1de547c3d2501e985917d5843fbbab11c9f8c2ad7bb2c7a1279a8
+SIZE (golang-sys-749cb33_GH0.tar.gz) = 1468012
+SHA256 (kardianos-osext-2bc1f35_GH0.tar.gz) = 1b771589ecc12d1449c5f9f7754b2149369cc76ca42eee0386b8c9a7434ceca9
+SIZE (kardianos-osext-2bc1f35_GH0.tar.gz) = 4899
+SHA256 (mitchellh-go-homedir-v1.1.0_GH0.tar.gz) = 646671c73a84a8dfb4a5a76b80c7b63549ffefa906524d45077301bc7da76600
+SIZE (mitchellh-go-homedir-v1.1.0_GH0.tar.gz) = 3362
+SHA256 (yitsushi-github-release-check-v1.0.1_GH0.tar.gz) = 8c651db3bf52967e04c8cead79787de0f4b1e74decbc4ea814b1de4f4de4c760
+SIZE (yitsushi-github-release-check-v1.0.1_GH0.tar.gz) = 1727
+SHA256 (yitsushi-go-commander-v1.1.0_GH0.tar.gz) = 197a9086fcdc81f2eba859a61fd0fe950f46904e3bdc7c2158b36995f953a8aa
+SIZE (yitsushi-go-commander-v1.1.0_GH0.tar.gz) = 23286
diff --git a/security/totp-cli/pkg-descr b/security/totp-cli/pkg-descr
new file mode 100644
index 000000000000..4a6beb2fb579
--- /dev/null
+++ b/security/totp-cli/pkg-descr
@@ -0,0 +1,5 @@
+This is a simple TOTP (Time-based One-time Password) CLI tool. TOTP is the most
+common mechanism for 2FA (Two-Factor-Authentication). You can manage and
+organize your accounts with namespaces and protect your data with a password.
+
+WWW: https://github.com/yitsushi/totp-cli