aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-31 03:56:43 +0800
committerkrion <krion@FreeBSD.org>2004-03-31 03:56:43 +0800
commit14042a07c94213103476ba10caba0e05d7386a88 (patch)
tree85ab7d332a60216705aba7ae5ea7bd5afd901b21 /security
parent17635d4d1428af00fc5c2d051fe401dc9e54a671 (diff)
downloadfreebsd-ports-gnome-14042a07c94213103476ba10caba0e05d7386a88.tar.gz
freebsd-ports-gnome-14042a07c94213103476ba10caba0e05d7386a88.tar.zst
freebsd-ports-gnome-14042a07c94213103476ba10caba0e05d7386a88.zip
- Use USE_ICONV knob
Approved by: portmgr
Diffstat (limited to 'security')
-rw-r--r--security/gnupg-devel/Makefile2
-rw-r--r--security/gnupg/Makefile2
-rw-r--r--security/gnupg1/Makefile2
-rw-r--r--security/newpg/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/security/gnupg-devel/Makefile b/security/gnupg-devel/Makefile
index e316e0b5ec9e..c7dd8fa6812a 100644
--- a/security/gnupg-devel/Makefile
+++ b/security/gnupg-devel/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= lofi@freebsd.org
COMMENT= Prerelease package of GnuPG extensions for GnuPG 2.0
LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt \
- iconv.3:${PORTSDIR}/converters/libiconv \
ksba.7:${PORTSDIR}/security/libksba \
pth.20:${PORTSDIR}/devel/pth
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
@@ -27,6 +26,7 @@ USE_AUTOCONF_VER=253
USE_LIBTOOL_VER=13
USE_GETTEXT= yes
USE_GMAKE= yes
+USE_ICONV= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index e880c79c94d0..ed09cd8b7a15 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -32,7 +32,7 @@ MAN7= gnupg.7
.include <bsd.port.pre.mk>
.if defined(WITH_LIBICONV) || exists(${PREFIX}/lib/libiconv.so)
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+USE_ICONV= yes
.endif
.if defined(WITH_LDAP) || exists(${PREFIX}/lib/libldap.so.2)
USE_OPENLDAP= yes
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index e880c79c94d0..ed09cd8b7a15 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -32,7 +32,7 @@ MAN7= gnupg.7
.include <bsd.port.pre.mk>
.if defined(WITH_LIBICONV) || exists(${PREFIX}/lib/libiconv.so)
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+USE_ICONV= yes
.endif
.if defined(WITH_LDAP) || exists(${PREFIX}/lib/libldap.so.2)
USE_OPENLDAP= yes
diff --git a/security/newpg/Makefile b/security/newpg/Makefile
index e316e0b5ec9e..c7dd8fa6812a 100644
--- a/security/newpg/Makefile
+++ b/security/newpg/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= lofi@freebsd.org
COMMENT= Prerelease package of GnuPG extensions for GnuPG 2.0
LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt \
- iconv.3:${PORTSDIR}/converters/libiconv \
ksba.7:${PORTSDIR}/security/libksba \
pth.20:${PORTSDIR}/devel/pth
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
@@ -27,6 +26,7 @@ USE_AUTOCONF_VER=253
USE_LIBTOOL_VER=13
USE_GETTEXT= yes
USE_GMAKE= yes
+USE_ICONV= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib