aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsimon <simon@FreeBSD.org>2006-03-26 19:14:02 +0800
committersimon <simon@FreeBSD.org>2006-03-26 19:14:02 +0800
commit152b8bba27899043ba5922cd89d19dd8049691cb (patch)
tree7420987c2f4a2f6c98af9642eac38cd6349bc553 /security
parent2de40b66977c139fc9aa15c9397c02dc7523605c (diff)
downloadfreebsd-ports-gnome-152b8bba27899043ba5922cd89d19dd8049691cb.tar.gz
freebsd-ports-gnome-152b8bba27899043ba5922cd89d19dd8049691cb.tar.zst
freebsd-ports-gnome-152b8bba27899043ba5922cd89d19dd8049691cb.zip
- Install an isakmpd rc.d startup script based on the ike startup script
in the base system. [1] - Do not quote BROKEN. - Remove USE_REINPLACE, when I'm here anyway. Postponed for way to long by: simon [1]
Diffstat (limited to 'security')
-rw-r--r--security/isakmpd/Makefile5
-rw-r--r--security/isakmpd/files/isakmpd.sh.in21
2 files changed, 24 insertions, 2 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index e46dae7dc4e7..42a22dadf9b2 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= isakmpd
PORTVERSION= 20041207
+PORTREVISION= 1
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= simon
@@ -16,7 +17,7 @@ COMMENT= OpenBSD IKE daemon
# this is not compatible with cross build - there's no other way
.if !exists(/usr/include/netinet6/ipsec.h)
-BROKEN= "requires IPsec support"
+BROKEN= requires IPsec support
.endif
# If keynote is in use, bring the dependency
@@ -24,8 +25,8 @@ BROKEN= "requires IPsec support"
BUILD_DEPENDS+= keynote:${PORTSDIR}/security/keynote
.endif
+USE_RC_SUBR= isakmpd.sh
USE_OPENSSL= yes
-USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/isakmpd
MAKE_ENV+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man LC_ALL=C
diff --git a/security/isakmpd/files/isakmpd.sh.in b/security/isakmpd/files/isakmpd.sh.in
new file mode 100644
index 000000000000..9e4514fdafe8
--- /dev/null
+++ b/security/isakmpd/files/isakmpd.sh.in
@@ -0,0 +1,21 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ike isakmpd
+# REQUIRE: root mountcritlocal
+# BEFORE: DAEMON
+# KEYWORD: nojail
+
+isakmpd_enable="${isakmpd_enable:-NO}"
+
+. /etc/rc.subr
+
+name="isakmpd"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/sbin/${name}"
+extra_commands="reload"
+
+load_rc_config $name
+run_rc_command "$1"