aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2016-04-29 23:41:40 +0800
committervsevolod <vsevolod@FreeBSD.org>2016-04-29 23:41:40 +0800
commit15974e0d2e0e9d89a11a3f1dd2f03c9acd9e74eb (patch)
tree2da3a2a1e037cb51ed2258bf3f1a505f3a290ede /security
parent991b14db3e292b6cefc278f25f0e8b9288be3044 (diff)
downloadfreebsd-ports-gnome-15974e0d2e0e9d89a11a3f1dd2f03c9acd9e74eb.tar.gz
freebsd-ports-gnome-15974e0d2e0e9d89a11a3f1dd2f03c9acd9e74eb.tar.zst
freebsd-ports-gnome-15974e0d2e0e9d89a11a3f1dd2f03c9acd9e74eb.zip
- Fix build with the recent libc++
PR: 209097 Submitted by: dim
Diffstat (limited to 'security')
-rw-r--r--security/hpenc/Makefile2
-rw-r--r--security/hpenc/files/patch-src_common.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index fd043eed9944..ce9ef1b50ebe 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hpenc
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://highsecure.ru/distfiles/
diff --git a/security/hpenc/files/patch-src_common.h b/security/hpenc/files/patch-src_common.h
new file mode 100644
index 000000000000..e1fbaa5c8ee4
--- /dev/null
+++ b/security/hpenc/files/patch-src_common.h
@@ -0,0 +1,11 @@
+--- src/common.h.orig 2014-10-21 15:58:03 UTC
++++ src/common.h
+@@ -28,7 +28,7 @@
+ // Ugly, ugly hack
+ #if defined(__clang__) && \
+ (__STDC_VERSION__ >= 201112L || __cplusplus >= 201103L) && \
+- !defined(__CLANG_MAX_ALIGN_T_DEFINED)
++ !defined(__CLANG_MAX_ALIGN_T_DEFINED) && !defined(_LIBCPP_STDDEF_H)
+ typedef struct {
+ long long __clang_max_align_nonce1
+ __attribute__((__aligned__(__alignof__(long long))));