aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-02-04 18:39:48 +0800
committerkoobs <koobs@FreeBSD.org>2016-02-04 18:39:48 +0800
commit1694191215b996e34bc10c17925914278f4a885b (patch)
treec6c985ead058c3b61f3c87e7f85ec1567a81abd0 /security
parent60861637ac70d8a926539079ec93d174907d1c1c (diff)
downloadfreebsd-ports-gnome-1694191215b996e34bc10c17925914278f4a885b.tar.gz
freebsd-ports-gnome-1694191215b996e34bc10c17925914278f4a885b.tar.zst
freebsd-ports-gnome-1694191215b996e34bc10c17925914278f4a885b.zip
security/py-rsa: Update to 3.3 (Fixes CVE-2016-1494)
- Update PORTVERSION and distinfo checksum (3.3) - Modernize TEST entries (test target, TEST_DEPENDS, et al) - Update setup.py patch (zip_safe no longer needed) - Add LICENSE_FILE - Enable NO_ARCH This version fixed a security vulnerability: https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-1494 PR: 206746 Reported by: Sevan Janiyan <venture37 geeklan co.uk> Security: e78bfc9d-cb1e-11e5-b251-0050562a4d7b Security: CVE-2016-1494 MFH: 2016Q1
Diffstat (limited to 'security')
-rw-r--r--security/py-rsa/Makefile18
-rw-r--r--security/py-rsa/distinfo4
-rw-r--r--security/py-rsa/files/patch-setup.py21
3 files changed, 21 insertions, 22 deletions
diff --git a/security/py-rsa/Makefile b/security/py-rsa/Makefile
index a2b9f27c479e..df0802c2bb73 100644
--- a/security/py-rsa/Makefile
+++ b/security/py-rsa/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rsa
-PORTVERSION= 3.1.4
-PORTREVISION= 1
+PORTVERSION= 3.3
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,20 +11,17 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Pure-Python RSA implementation
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.3:${PORTSDIR}/devel/py-pyasn1
-TEST_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2 \
- ${RUN_DEPENDS}
-
-OPTIONS_DEFINE= TESTS
-
-TESTS_DESC= Install tools for unit tests
-TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
-regression-test: build
+do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} run_tests.py
.include <bsd.port.mk>
diff --git a/security/py-rsa/distinfo b/security/py-rsa/distinfo
index de35e96f2376..968de6ed220b 100644
--- a/security/py-rsa/distinfo
+++ b/security/py-rsa/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rsa-3.1.4.tar.gz) = e2b0b05936c276b1edd2e1525553233b666df9e29b5c3ba223eed738277c82a0
-SIZE (rsa-3.1.4.tar.gz) = 36181
+SHA256 (rsa-3.3.tar.gz) = 03f3d9bebad06681771016b8752a40b12f615ff32363c7aa19b3798e73ccd615
+SIZE (rsa-3.3.tar.gz) = 33449
diff --git a/security/py-rsa/files/patch-setup.py b/security/py-rsa/files/patch-setup.py
index 4bfa12e73943..af3c4c48c51f 100644
--- a/security/py-rsa/files/patch-setup.py
+++ b/security/py-rsa/files/patch-setup.py
@@ -1,9 +1,12 @@
---- ./setup.py.orig 2013-09-26 22:34:41.233363167 +1000
-+++ ./setup.py 2013-09-26 22:34:50.192985862 +1000
-@@ -42,5 +42,5 @@
- 'pyrsa-encrypt-bigfile = rsa.cli:encrypt_bigfile',
- 'pyrsa-decrypt-bigfile = rsa.cli:decrypt_bigfile',
- ]},
--
-+ zip_safe=False,
- )
+--- setup.py.orig 2016-01-13 08:43:51 UTC
++++ setup.py
+@@ -42,6 +42,9 @@ setup(name='rsa',
+ install_requires=[
+ 'pyasn1 >= 0.1.3',
+ ],
++ tests_require=[
++ 'unittest2',
++ ],
+ entry_points={'console_scripts': [
+ 'pyrsa-priv2pub = rsa.util:private_to_public',
+ 'pyrsa-keygen = rsa.cli:keygen',