aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2010-03-18 14:33:38 +0800
committerjohans <johans@FreeBSD.org>2010-03-18 14:33:38 +0800
commit16e97c8f0332be80946760ebc7b53cd849601337 (patch)
tree3ebf74db424ddd589b8152be547f5b5fbde50ee4 /security
parenta8e240d29fed47c5d0dcba1e28ec708563da1fb8 (diff)
downloadfreebsd-ports-gnome-16e97c8f0332be80946760ebc7b53cd849601337.tar.gz
freebsd-ports-gnome-16e97c8f0332be80946760ebc7b53cd849601337.tar.zst
freebsd-ports-gnome-16e97c8f0332be80946760ebc7b53cd849601337.zip
- Update to 0.0.42
- Add patch for FreeBSD <=7 where configure rejects our stat() but cannot use the included version either. Use ours anyway.
Diffstat (limited to 'security')
-rw-r--r--security/shishi/Makefile14
-rw-r--r--security/shishi/Makefile.man5
-rw-r--r--security/shishi/distinfo6
-rw-r--r--security/shishi/pkg-plist2
4 files changed, 22 insertions, 5 deletions
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index f81663d8e064..8cd89ba53002 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= shishi
-PORTVERSION= 0.0.40
+PORTVERSION= 0.0.42
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -48,8 +48,20 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+.if ${OSVERSION} < 800000
+CONFIGURE_ARGS+= gl_cv_func_stat_dir_slash="guessing yes" \
+ gl_cv_func_stat_file_slash="guessing yes"
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/shishi.info*
+ @cd ${WRKSRC}/db/gl && ${LN} -s ../../build-aux/link-warning.h
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/$$(LINK_WARNING_H)/link-warning.h/' \
+ ${WRKSRC}/db/gl/Makefile.in
+ @${REINPLACE_CMD} -e 's:\.\./gl/libgnu.la:../db/gl/libgnu.la &:' \
+ ${WRKSRC}/src/Makefile.in
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/security/shishi/Makefile.man b/security/shishi/Makefile.man
index 769858bc4a9b..52a8118719d7 100644
--- a/security/shishi/Makefile.man
+++ b/security/shishi/Makefile.man
@@ -401,6 +401,8 @@ MAN3+= shishi_key_print.3
MAN3+= shishi_key_random.3
MAN3+= shishi_key_realm.3
MAN3+= shishi_key_realm_set.3
+MAN3+= shishi_key_timestamp.3
+MAN3+= shishi_key_timestamp_set.3
MAN3+= shishi_key_to_file.3
MAN3+= shishi_key_type.3
MAN3+= shishi_key_type_set.3
@@ -418,11 +420,14 @@ MAN3+= shishi_keys_for_server_in_file.3
MAN3+= shishi_keys_for_serverrealm_in_file.3
MAN3+= shishi_keys_from_keytab_file.3
MAN3+= shishi_keys_from_keytab_mem.3
+MAN3+= shishi_keys_from_file.3
MAN3+= shishi_keys_nth.3
MAN3+= shishi_keys_print.3
MAN3+= shishi_keys_remove.3
MAN3+= shishi_keys_size.3
MAN3+= shishi_keys_to_file.3
+MAN3+= shishi_keys_to_keytab_file.3
+MAN3+= shishi_keys_to_keytab_mem.3
MAN3+= shishi_krberror.3
MAN3+= shishi_krberror_build.3
MAN3+= shishi_krberror_client.3
diff --git a/security/shishi/distinfo b/security/shishi/distinfo
index a910066e4195..642657577d1a 100644
--- a/security/shishi/distinfo
+++ b/security/shishi/distinfo
@@ -1,3 +1,3 @@
-MD5 (shishi-0.0.40.tar.gz) = 9935d00c1246ba7c85302e0a26902054
-SHA256 (shishi-0.0.40.tar.gz) = a07b1fbf93aabf30dd9867a8a786ec21ed5f51ef8bb37eaa2a7e5171b7919a1d
-SIZE (shishi-0.0.40.tar.gz) = 3817400
+MD5 (shishi-0.0.42.tar.gz) = aca127c56de9b4c9deef34578acf5b46
+SHA256 (shishi-0.0.42.tar.gz) = 72bcf9215cf271fa4958976143a13130f9d6a6f9078c7472fdcf6fc78647f0ca
+SIZE (shishi-0.0.42.tar.gz) = 4231227
diff --git a/security/shishi/pkg-plist b/security/shishi/pkg-plist
index e04ed64d72dc..af8b5d589002 100644
--- a/security/shishi/pkg-plist
+++ b/security/shishi/pkg-plist
@@ -5,8 +5,8 @@ sbin/keytab2shishi
sbin/shishid
etc/shishi/shisa.conf
etc/shishi/shishi.conf
-etc/shishi/shishi.skel
etc/shishi/shishi.keys
+etc/shishi/shishi.skel
include/shisa.h
include/shishi-int.h
include/shishi.h