aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2011-07-27 06:12:14 +0800
committergarga <garga@FreeBSD.org>2011-07-27 06:12:14 +0800
commit17820f2587bb047f565bb3d4de8a473203165fc3 (patch)
tree9cbce9f6a04001fc09bc2b8cef4639c6e1f9ff4d /security
parentc6abd56a5a4abf58aaa37c314b72bba21e89baa0 (diff)
downloadfreebsd-ports-gnome-17820f2587bb047f565bb3d4de8a473203165fc3.tar.gz
freebsd-ports-gnome-17820f2587bb047f565bb3d4de8a473203165fc3.tar.zst
freebsd-ports-gnome-17820f2587bb047f565bb3d4de8a473203165fc3.zip
Respect $CC, it fixes build with clang
Diffstat (limited to 'security')
-rw-r--r--security/checkpassword/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/checkpassword/Makefile b/security/checkpassword/Makefile
index f30b606e2265..6a7cc4225315 100644
--- a/security/checkpassword/Makefile
+++ b/security/checkpassword/Makefile
@@ -23,7 +23,11 @@ MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/checkpassword
PORTDOCS= CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+post-patch:
+ @${REINPLACE_CMD} -e "s/gcc/${CC}/g" ${WRKSRC}/find-systype.sh
+
do-configure:
+ @${ECHO_CMD} '${CC} ${CFLAGS} -s -lcrypt' > ${WRKSRC}/conf-cc
@${ECHO_CMD} '${CC} ${CFLAGS} -s -lcrypt' > ${WRKSRC}/conf-ld
@${ECHO_CMD} ${PREFIX} >${WRKSRC}/conf-home